Rhino C++ API
8.13
|
#include <IRhRdkTextureEvaluator.h>
Classes | |
struct | WRITE_TO_BYTE_DATA |
struct | WRITE_TO_FLOAT_DATA |
Public Member Functions | |
bool | AdjustmentOn (void) const |
virtual const IChildCallback * | ChildCallback (void) const override |
const CEvalFlags & | EvaluatorFlags (void) const |
virtual void * | EVF (const wchar_t *, void *) override |
bool | FilteringOn (void) const |
virtual bool | Initialize (void) override |
bool | LocalMappingOn (void) const |
bool | ProjectionChangeOn (void) const |
virtual bool | RegisterChildCallback (IChildCallback *pChildCallback, const CRhRdkTexture &texture, void *pvData) override |
Public Member Functions inherited from CRhRdkObject | |
CRhRdkObject () | |
virtual | ~CRhRdkObject () |
void | operator delete (void *buf) |
void | operator delete[] (void *buf) |
void * | operator new (size_t size) |
void * | operator new[] (size_t size) |
Public Member Functions inherited from IRhRdkTextureEvaluator | |
virtual void | DeleteThis (void)=0 |
virtual bool | GetColor (const ON_3dPoint &uvw, const ON_3dVector &duvwdx, const ON_3dVector &duvwdy, CRhRdkColor &colOut, void *pvData=NULL) const =0 |
bool | WriteByteArray (const ON_2iSize &size, unsigned char *buffer) const |
bool | WriteFloatArray (const ON_2iSize &size, float *buffer) const |
Protected Member Functions | |
CRhRdkTextureEvaluator (IRhRdkTextureEvaluator::CEvalFlags ef) | |
virtual | ~CRhRdkTextureEvaluator () |
Protected Member Functions inherited from IRhRdkTextureEvaluator | |
virtual | ~IRhRdkTextureEvaluator () |
Additional Inherited Members | |
Static Public Member Functions inherited from CRhRdkObject | |
static void | CheckMemory (void) |
static void | PopulateDebuggingInfo (void) |
This is the default base class implementation of IRhRdkTextureEvaluator.
|
protectedvirtual |
|
protected |
bool CRhRdkTextureEvaluator::AdjustmentOn | ( | void | ) | const |
|
overridevirtual |
Implements IRhRdkTextureEvaluator::ChildCallback().
Implements IRhRdkTextureEvaluator.
const CEvalFlags& CRhRdkTextureEvaluator::EvaluatorFlags | ( | void | ) | const |
|
overridevirtual |
Emergency virtual function for future expansion.
Implements IRhRdkTextureEvaluator.
Reimplemented in CRhRdkOneColorEvaluator.
bool CRhRdkTextureEvaluator::FilteringOn | ( | void | ) | const |
|
overridevirtual |
Default implementation calls GetColor(ON_origin...).
Implements IRhRdkTextureEvaluator.
bool CRhRdkTextureEvaluator::LocalMappingOn | ( | void | ) | const |
bool CRhRdkTextureEvaluator::ProjectionChangeOn | ( | void | ) | const |
|
overridevirtual |
Implements IRhRdkTextureEvaluator::RegisterChildCallback().
Implements IRhRdkTextureEvaluator.
Reimplemented in CRhRdkTwoColorEvaluator, and CRhRdkOneColorEvaluator.