Rhino C++ API
8.13
|
#include <rhinoSdkMeshObject.h>
Public Member Functions | |
CRhinoMeshStlUI () | |
virtual | ~CRhinoMeshStlUI () |
CRhinoCommand::result | GetMeshParameters (const ON_SimpleArray< const CRhinoObject * > &objects, ON_MeshParameters &mp) |
Override of pure virtual CRhinoMeshObjectsUI. More... | |
void | LoadProfile (LPCTSTR lpszSection, CRhinoProfileContext &pc) |
void | SaveProfile (LPCTSTR lpszSection, CRhinoProfileContext &pc) |
void | SetValuesFromMeshParameters (const ON_MeshParameters &, bool bDetailed) |
Public Member Functions inherited from CRhinoMeshObjectsUI | |
CRhinoMeshObjectsUI () | |
virtual | ~CRhinoMeshObjectsUI () |
bool | OnCancelPreview () |
int | OnPreview (const ON_MeshParameters &mp) |
Static Public Member Functions | |
static int | MeshQuality (const ON_MeshParameters &mp) |
static double | MeshTolerance (const ON_MeshParameters &mp) |
static void | SetMeshParameters (int quality, double tolerance, ON_MeshParameters &mp) |
Public Attributes | |
int | m_command_style |
int | m_detailed_dlg |
starting dialog type More... | |
double | m_grid_aspect_ratio |
default = 6.0 More... | |
int | m_grid_min_count |
16; More... | |
double | m_max_edge_length |
default = 0.0 More... | |
int | m_mesh_quality |
0 = course, 1 = medium, 2 = fine (default=1) More... | |
double | m_mesh_tolerance |
mesh tolerance is ignored if <= 0.0 (default=0.0) More... | |
double | m_refine_angle |
20.0*ON_PI/180.0; More... | |
double | m_relative_tolerance |
The new Rhino 4 mesh Density setting. Initially set to 0. More... | |
ON_wString | m_title_str |
dialog title More... | |
ON_wString | m_tolerance_str |
tolerance description string More... | |
Public Attributes inherited from CRhinoMeshObjectsUI | |
class CRhinoMeshWorkerThread * | m__meshworker |
Pretend these are private. Don't look and don't touch. More... | |
AFX_MODULE_STATE * | m__pModuleState |
Description: Creates the course/medium/fine + optional tolerance dialog used for STL export.
CRhinoMeshStlUI::CRhinoMeshStlUI | ( | ) |
|
virtual |
|
virtual |
Override of pure virtual CRhinoMeshObjectsUI.
Implements CRhinoMeshObjectsUI.
void CRhinoMeshStlUI::LoadProfile | ( | LPCTSTR | lpszSection, |
CRhinoProfileContext & | pc | ||
) |
Description: Loads settings from the Rhino profile. Parameters: lpszSection - [in] profile section to use for this command pc - [in] profile context to use to get at value saved in the Rhino profile.
|
static |
Description: Get quality setting from mesh parameters. Parameters: mp - [in] Returns Quality setting:
0 = course, 1 = medium, 2 = fine
|
static |
Description: Get tolerance setting from mesh parameters. Parameters: mp - [in] Returns Tolerance
void CRhinoMeshStlUI::SaveProfile | ( | LPCTSTR | lpszSection, |
CRhinoProfileContext & | pc | ||
) |
Description: Save settings to the Rhino profile. Parameters: lpszSection - [in] profile section to use for this command pc - [in] profile context to use to get at value saved in the Rhino profile.
|
static |
Description: Sets meshing parameters from simple quality and tolerance settings. Parameters: quality - [in] 0 = course, 1 = medium, 2 = fine tolerance - [in] mesh tolerance (ignored if <= 0.0) mp - [out]
void CRhinoMeshStlUI::SetValuesFromMeshParameters | ( | const ON_MeshParameters & | , |
bool | bDetailed | ||
) |
int CRhinoMeshStlUI::m_command_style |
Specifies style of command using this UI CRhinoCommandContext::interactive_ui CRhinoCommandContext::script_ui CRhinoCommandContext::batch_ui (default=interactive_ui)
int CRhinoMeshStlUI::m_detailed_dlg |
starting dialog type
0 = stl dialog, 1 = detailed dialog
double CRhinoMeshStlUI::m_grid_aspect_ratio |
default = 6.0
int CRhinoMeshStlUI::m_grid_min_count |
16;
double CRhinoMeshStlUI::m_max_edge_length |
default = 0.0
int CRhinoMeshStlUI::m_mesh_quality |
0 = course, 1 = medium, 2 = fine (default=1)
double CRhinoMeshStlUI::m_mesh_tolerance |
mesh tolerance is ignored if <= 0.0 (default=0.0)
double CRhinoMeshStlUI::m_refine_angle |
20.0*ON_PI/180.0;
double CRhinoMeshStlUI::m_relative_tolerance |
The new Rhino 4 mesh Density setting. Initially set to 0.
ON_wString CRhinoMeshStlUI::m_title_str |
dialog title
ON_wString CRhinoMeshStlUI::m_tolerance_str |
tolerance description string