Rhino C++ API
8.13
|
#include <RhinoSdkPages.h>
Public Member Functions | |
CRhinoOptionsPageEventArgs (class IRhinoOptionsPageHost *host) | |
CRhinoOptionsPageEventArgs (const CRhinoOptionsPageEventArgs &src) | |
~CRhinoOptionsPageEventArgs () | |
CRhinoDoc * | Document () const |
unsigned int | DocumentRuntimeSerialNumber () const |
class IRhinoOptionsPageHost * | Host () const |
const CRhinoOptionsPageEventArgs & | operator= (const CRhinoOptionsPageEventArgs &src) |
class CRhinoOptionsPageEventArgs
Description: Arguments class passed to IRhinoOptionsPage notification methods.
CRhinoOptionsPageEventArgs::CRhinoOptionsPageEventArgs | ( | class IRhinoOptionsPageHost * | host | ) |
Description: Default constructor. Parameters: documentRuntimeSerailNumber [in] = The document associated with this event
CRhinoOptionsPageEventArgs::~CRhinoOptionsPageEventArgs | ( | ) |
Description: Destructor.
CRhinoOptionsPageEventArgs::CRhinoOptionsPageEventArgs | ( | const CRhinoOptionsPageEventArgs & | src | ) |
Description: Copy constructor.
CRhinoDoc* CRhinoOptionsPageEventArgs::Document | ( | ) | const |
Description: Call this method to get the associated host document. Returns: The associated host document.
unsigned int CRhinoOptionsPageEventArgs::DocumentRuntimeSerialNumber | ( | ) | const |
Description: Call this method to get the associated host documents runtime serial number. Returns: The associated host documents runtime serial number.
class IRhinoOptionsPageHost* CRhinoOptionsPageEventArgs::Host | ( | ) | const |
Description: The Options page host.
const CRhinoOptionsPageEventArgs& CRhinoOptionsPageEventArgs::operator= | ( | const CRhinoOptionsPageEventArgs & | src | ) |
Description: Operator =