Rhino C++ API  8.6
Public Member Functions | Protected Member Functions | List of all members
IRhinoOptionsPageHost Class Referenceabstract

#include <RhinoSdkPages.h>

Inheritance diagram for IRhinoOptionsPageHost:
IRhinoPageHost

Public Member Functions

virtual int AddChild (class IRhinoOptionsPage *child, unsigned int documentRuntimeSerialNumber)=0
 
virtual int AddChild (IRhinoOptionsPageHost *child)=0
 
virtual void MakeActivePage ()=0
 
virtual IRhinoOptionsPageHostParent ()=0
 
virtual void RefreshPageTitle ()=0
 
virtual bool RemoveChild (IRhinoOptionsPageHost *childToRemove, bool releaseChildPage)=0
 
- Public Member Functions inherited from IRhinoPageHost
virtual ~IRhinoPageHost ()=default
 
virtual void ChangeDefaultSize (ON_2iSize newSize)=0
 
virtual void Created ()=0
 
virtual unsigned int DocumentRuntimeSerialNumber () const =0
 
virtual IRhinoPagePage () const =0
 
virtual LPARAM PageHostProc (unsigned int message, WPARAM wParam, LPARAM lParam)
 
virtual void SizedChanged (ON_2iSize size)=0
 
virtual void VisibleChanged (bool visible)=0
 
virtual RHINO_WINDOW_HANDLE Window () const =0
 

Protected Member Functions

 IRhinoOptionsPageHost ()=default
 
 IRhinoOptionsPageHost (const IRhinoOptionsPageHost &)=delete
 
IRhinoOptionsPageHostoperator= (const IRhinoOptionsPageHost &)=delete
 
- Protected Member Functions inherited from IRhinoPageHost
 IRhinoPageHost ()=default
 
 IRhinoPageHost (const IRhinoPageHost &)=delete
 
IRhinoPageHostoperator= (const IRhinoPageHost &)=delete
 

Detailed Description

class IRhinoPropertiesPanelPageHost

Description: Provides access the object properties panel page host.

Constructor & Destructor Documentation

◆ IRhinoOptionsPageHost() [1/2]

IRhinoOptionsPageHost::IRhinoOptionsPageHost ( )
protecteddefault

Description: Default constructor.

◆ IRhinoOptionsPageHost() [2/2]

IRhinoOptionsPageHost::IRhinoOptionsPageHost ( const IRhinoOptionsPageHost )
protecteddelete

Description: Delete the default copy constructor

Member Function Documentation

◆ AddChild() [1/2]

virtual int IRhinoOptionsPageHost::AddChild ( class IRhinoOptionsPage child,
unsigned int  documentRuntimeSerialNumber 
)
pure virtual

Description: This must be implemented and may be used to store child pages if supported. Parameters: child[in] The new host object to add as a child. documentRuntimeSerialNumber[in] The runtime serial number for the document associated with the child page. Returns: Returns the index for the new child item or -1 if something went wrong.

◆ AddChild() [2/2]

virtual int IRhinoOptionsPageHost::AddChild ( IRhinoOptionsPageHost child)
pure virtual

Description: This must be implemented and may be used to store child pages if supported. Parameters: child[in] The new host object to add as a child. Returns: Returns the index for the new child item or -1 if something went wrong.

◆ MakeActivePage()

virtual void IRhinoOptionsPageHost::MakeActivePage ( )
pure virtual

Description: This must be implemented and may be used to set the active page. Parameters: page[in] The page to set as the active page

◆ operator=()

IRhinoOptionsPageHost& IRhinoOptionsPageHost::operator= ( const IRhinoOptionsPageHost )
protecteddelete

Description: Delete the default operator=

◆ Parent()

virtual IRhinoOptionsPageHost* IRhinoOptionsPageHost::Parent ( )
pure virtual

Description: Call this method to get the parent host for this page host. Returns: Returns the parent or null if there is none.

◆ RefreshPageTitle()

virtual void IRhinoOptionsPageHost::RefreshPageTitle ( )
pure virtual

Description: Call this method to update the host dialog reference to this pages tile string.

◆ RemoveChild()

virtual bool IRhinoOptionsPageHost::RemoveChild ( IRhinoOptionsPageHost childToRemove,
bool  releaseChildPage 
)
pure virtual

Description: This must be implemented and may be used to remove a child page if child pages are supported. Parameters: child[in] The child page to remove. releaseChildPage[in] If true and the child page is successfully removed then Release will be called on the page. Returns: Returns the index for the new child item or -1 if something went wrong.