#include <rhinoSdkView.h>
◆ CRhinoPageViewIterator()
CRhinoPageViewIterator::CRhinoPageViewIterator |
( |
unsigned int |
rhino_doc_sn | ) |
|
Parameters: rhino_doc_sn - [in] 0: iterate all views of all documents. >0: iteration all views of the specified doc.
◆ CurrentView()
Returns: The current value of the iterator. Remarks:
◆ CurrentViewRuntimeSerialNumber()
unsigned int CRhinoPageViewIterator::CurrentViewRuntimeSerialNumber |
( |
| ) |
const |
◆ DocRuntimeSerialNumber()
unsigned int CRhinoPageViewIterator::DocRuntimeSerialNumber |
( |
| ) |
const |
Example: Iteratate all page views: unsigned int rhino_doc_sn = 0 or doc->RuntimeSerialNumber(); CRhinoDocIterator doc_it(rhino_doc_sn); for ( CRhinoPageView* rhino_page_view = view_it.First(); 0 != rhino_page_view; rhino_page_view = view_it.Next() ) { ... }
◆ First()
Returns: The first page view that exists. Remarks: You may call First() multiple times on the same iterator.
◆ Next()
Returns: The next page view that exists. Remarks:
- Once Next() returns null, it will continue to return null until First() is called.
- If First() has not be called, the first call to Next() returns the first view in Rhino. This is done so that people can write while loops like CRhinoViewIterator it(rhino_doc_sn); while ( CRhinoView* rhino_view = it.Next() ) { ... }