#include <rhinoSdkEventWatcher.h>
◆ PlugInId()
ON_UUID CRhinoPlugInSettingsChanged::CParameters::PlugInId |
( |
| ) |
const |
Description: The plug-in associated with the CRhinoSettings being saved.
◆ Settings()
CRhinoSettings& CRhinoPlugInSettingsChanged::CParameters::Settings |
( |
| ) |
const |
Description: The CRhinoSettings read from the current settings file, compare these values to the CRinoPlugIn::Settings() values to see if anything you care about changed.
◆ ThisRhinoIsSaving()
bool CRhinoPlugInSettingsChanged::CParameters::ThisRhinoIsSaving |
( |
| ) |
const |
◆ RhCallWatcher_PlugInSettingsChanged
void RhCallWatcher_PlugInSettingsChanged |
( |
ON_UUID |
plugInId, |
|
|
unsigned int |
pointerId, |
|
|
bool |
thisRhinoIsSaving |
|
) |
| |
|
friend |