Rhino C++ API
8.17
|
#include <rhinoSdkCommand.h>
Public Member Functions | |
CRhinoTransformCommand (bool bTransparent=false, bool bDoNotRepeat=false, const class CRhinoPlugIn *pPlugIn=nullptr, bool bTestCommand=false) | |
unsigned int | DefaultGeometryFilter () const |
void | DuplicateObjects (CRhinoDoc &doc, class CRhinoXformObjectList &list) |
bool | ObjectsWerePreSelected () |
void | ResetGrips (CRhinoDoc &doc, class CRhinoXformObjectList &list) |
CRhinoCommand::result | SelectObjects (const wchar_t *prompt, class CRhinoXformObjectList &list) |
CRhinoCommand::result | SelectObjects (const wchar_t *prompt, class CRhinoXformObjectList &list, bool bAllowAllGrips) |
CRhinoCommand::result | SelectObjects (const wchar_t *prompt, unsigned int geometry_filter, class CRhinoXformObjectList &list) |
CRhinoCommand::result | SelectObjects (const wchar_t *prompt, unsigned int geometry_filter, class CRhinoXformObjectList &list, bool bAllowAllGrips) |
void | TransformObjects (CRhinoDoc &doc, class CRhinoXformObjectList &list, ON_Xform &xform, BOOL32 bCopy=FALSE, BOOL32 bAutoHistory=FALSE) |
CRhinoView * | View () |
![]() | |
CRhinoCommand (bool bTransparent=false, bool bDoNotRepeat=false, const class CRhinoPlugIn *pPlugIn=nullptr, bool bTestCommand=false) | |
virtual | ~CRhinoCommand () |
const unsigned int & | CommandFlags () const |
UUID | CommandId () const |
virtual UUID | CommandUUID ()=0 |
!! See cmdExample.cpp for instructions on the use of this class. !! ///< More... | |
virtual bool | ContextHelpURL (ON_wString &url) const |
virtual void | DoHelp () |
Override this function to display help for this command. More... | |
virtual void | DynamicDraw (class CRhinoView &) |
virtual CRhinoObject * | EditObjects (const class CRhinoHistoryRecord &history_record, ON_SimpleArray< CRhinoObjectPair > &results) |
void | EnableHistoryReplayOnObjectAttributeChange (bool bEnable=true) |
void | EnableRepeatable (BOOL32 bRepeatable=true) |
void | EnableUndo (bool bUndoable=true) |
virtual const wchar_t * | EnglishCommandName () const |
virtual const wchar_t * | EnglishCommandName ()=0 |
bool | HistoryReplayOnObjectAttributeChange () const |
bool | IsAlphaCommand () const |
Returns true if a command is an "alpha" command. More... | |
bool | IsRepeatable () const |
bool | IsScriptRunnerCommand () const |
bool | IsSystem () const |
bool | IsTestCommand () const |
bool | IsTransparent () const |
bool | IsUndoable () const |
virtual void | LoadProfile (LPCTSTR lpszSection, CRhinoProfileContext &pc) |
virtual const wchar_t * | LocalCommandName () const |
const class CRhinoPlugIn * | PlugIn () const |
virtual CRhinoObject * | ReplayHistory (const class CRhinoHistoryRecord &history_record) |
virtual bool | ReplayHistory (const class CRhinoHistoryRecord &history_record, ON_SimpleArray< CRhinoObjectPair > &results) |
virtual CRhinoCommand::result | RunCommand (const CRhinoCommandContext &)=0 |
virtual void | SaveProfile (LPCTSTR lpszSection, CRhinoProfileContext &pc) |
CRhinoSettings & | Settings () |
Additional Inherited Members | |
![]() | |
enum | result { success = 0, cancel = 1, nothing = 2, failure, unknown_command, cancel_modeless_dialog, exit_rhino = 0x0FFFFFFF } |
![]() | |
static bool | IsValidCommandName (const wchar_t *) |
Description: Base class for all transformation-type commands.
CRhinoTransformCommand::CRhinoTransformCommand | ( | bool | bTransparent = false , |
bool | bDoNotRepeat = false , |
||
const class CRhinoPlugIn * | pPlugIn = nullptr , |
||
bool | bTestCommand = false |
||
) |
unsigned int CRhinoTransformCommand::DefaultGeometryFilter | ( | ) | const |
void CRhinoTransformCommand::DuplicateObjects | ( | CRhinoDoc & | doc, |
class CRhinoXformObjectList & | list | ||
) |
|
inline |
void CRhinoTransformCommand::ResetGrips | ( | CRhinoDoc & | doc, |
class CRhinoXformObjectList & | list | ||
) |
Description: sets dynamic grip locations back to starting grip locations. This makes things like the Copy command work when grips are "copied".
CRhinoCommand::result CRhinoTransformCommand::SelectObjects | ( | const wchar_t * | prompt, |
class CRhinoXformObjectList & | list | ||
) |
CRhinoCommand::result CRhinoTransformCommand::SelectObjects | ( | const wchar_t * | prompt, |
class CRhinoXformObjectList & | list, | ||
bool | bAllowAllGrips | ||
) |
CRhinoCommand::result CRhinoTransformCommand::SelectObjects | ( | const wchar_t * | prompt, |
unsigned int | geometry_filter, | ||
class CRhinoXformObjectList & | list | ||
) |
CRhinoCommand::result CRhinoTransformCommand::SelectObjects | ( | const wchar_t * | prompt, |
unsigned int | geometry_filter, | ||
class CRhinoXformObjectList & | list, | ||
bool | bAllowAllGrips | ||
) |
void CRhinoTransformCommand::TransformObjects | ( | CRhinoDoc & | doc, |
class CRhinoXformObjectList & | list, | ||
ON_Xform & | xform, | ||
BOOL32 | bCopy = FALSE , |
||
BOOL32 | bAutoHistory = FALSE |
||
) |
|
inline |