Rhino C++ API
8.13
|
CRhinoUiGridListHeaderCtrl. More...
#include <RhinoSdkUiGridListHeaderCtrl.h>
Public Member Functions | |
CRhinoUiGridListHeaderCtrl () | |
virtual | ~CRhinoUiGridListHeaderCtrl () |
bool | AllowColumnResizing () |
void | AllowColumnResizing (bool b) |
int | ColumnFromPoint (CPoint point) |
bool | ColumnResizable (int nColumn) |
int | CursorColumnFromPoint (CPoint point) |
void | DisableColumResizing (int nInColumn) |
LPARAM | GetColumnLParam (int nCol) |
CListCtrl * | ListCtrl () |
afx_msg void | OnLButtonDblClk (UINT nFlags, CPoint point) |
afx_msg LRESULT | OnNcHitTest (CPoint point) |
afx_msg BOOL32 | OnSetCursor (CWnd *pWnd, UINT nHitTest, UINT message) |
Protected Attributes | |
bool | m_bAllowColumnResizing |
CUIntArray | m_DisableColumnSizingList |
int | m_nCursorColumn |
/ / Copyright (c) 1993-2007 Robert McNeel & Associates. All rights reserved. / Rhinoceros is a registered trademark of Robert McNeel & Associates. / / THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. / ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF / MERCHANTABILITY ARE HEREBY DISCLAIMED. /
/ For complete Rhino SDK copyright information see http://www.rhino3d.com/developer. / //////////////////////////////////////////////////////////////
CRhinoUiGridListHeaderCtrl::CRhinoUiGridListHeaderCtrl | ( | ) |
|
virtual |
bool CRhinoUiGridListHeaderCtrl::AllowColumnResizing | ( | ) |
void CRhinoUiGridListHeaderCtrl::AllowColumnResizing | ( | bool | b | ) |
int CRhinoUiGridListHeaderCtrl::ColumnFromPoint | ( | CPoint | point | ) |
bool CRhinoUiGridListHeaderCtrl::ColumnResizable | ( | int | nColumn | ) |
int CRhinoUiGridListHeaderCtrl::CursorColumnFromPoint | ( | CPoint | point | ) |
void CRhinoUiGridListHeaderCtrl::DisableColumResizing | ( | int | nInColumn | ) |
LPARAM CRhinoUiGridListHeaderCtrl::GetColumnLParam | ( | int | nCol | ) |
CListCtrl* CRhinoUiGridListHeaderCtrl::ListCtrl | ( | ) |
afx_msg void CRhinoUiGridListHeaderCtrl::OnLButtonDblClk | ( | UINT | nFlags, |
CPoint | point | ||
) |
afx_msg LRESULT CRhinoUiGridListHeaderCtrl::OnNcHitTest | ( | CPoint | point | ) |
afx_msg BOOL32 CRhinoUiGridListHeaderCtrl::OnSetCursor | ( | CWnd * | pWnd, |
UINT | nHitTest, | ||
UINT | message | ||
) |
|
protected |
|
protected |
|
protected |