Rhino C++ API
8.13
|
#include <RhinoSdkUiXML.h>
Public Member Functions | |
CRuiOnUpdateMenuItem () | |
CRuiOnUpdateMenuItem (const wchar_t *idFile, const wchar_t *idMenu, const wchar_t *idItem) | |
CRuiOnUpdateMenuItem (UUID idFile, UUID idMenu, UUID idItem) | |
const UUID & | FileID () const |
bool | IsEqualTo (UUID idFile, UUID idMenu, UUID idItem) const |
const UUID & | MenuID () const |
const UUID & | MenuItemID () const |
Public Attributes | |
class CRhDockBarExtension * | m__update_menu_item_extension |
Protected Attributes | |
UUID | m_idFile |
File ID. More... | |
UUID | m_idItem |
Menu item ID. More... | |
UUID | m_idMenu |
Menu ID. More... | |
Copyright (c) 1993-2017 Robert McNeel & Associates. All rights reserved. Rhinoceros is a registered trademark of Robert McNeel & Associates.
THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF MERCHANTABILITY ARE HEREBY DISCLAIMED.
For complete Rhino SDK copyright information see http://www.rhino3d.com/developer. ==========================================================================================
Description: For internal use. Used by CRuiOnUpdateMenuItems to track registered menu items
CRuiOnUpdateMenuItem::CRuiOnUpdateMenuItem | ( | ) |
Description: Default constructor
CRuiOnUpdateMenuItem::CRuiOnUpdateMenuItem | ( | UUID | idFile, |
UUID | idMenu, | ||
UUID | idItem | ||
) |
Description: Constructor to allow easy initialization
CRuiOnUpdateMenuItem::CRuiOnUpdateMenuItem | ( | const wchar_t * | idFile, |
const wchar_t * | idMenu, | ||
const wchar_t * | idItem | ||
) |
Description: Constructor to allow easy initialization
|
inline |
Description: File ID associated with this item
Returns; File ID associated with this item
bool CRuiOnUpdateMenuItem::IsEqualTo | ( | UUID | idFile, |
UUID | idMenu, | ||
UUID | idItem | ||
) | const |
Description: Check to see if this item is equal to specified IDs
Parameters: idFile [in] The UUID of the file that contains the menu item idMenu [in] The UUID of the menu that contains the menu item, this may be a sub men ID idItem [in] The UUID of the menu item to update
Returns; Returns true if m_idFile == idFile and m_idMenu == idMenu and m_idItem == idItem
|
inline |
Description: Menu ID associated with this item
Returns; Menu ID associated with this item
|
inline |
Description: Menu item ID associated with this item
Returns; Menu item ID associated with this item
class CRhDockBarExtension* CRuiOnUpdateMenuItem::m__update_menu_item_extension |
For internal use only! Reserved for future use.
|
protected |
File ID.
|
protected |
Menu item ID.
|
protected |
Menu ID.