Rhino C++ API  8.6
Public Member Functions | Static Public Member Functions | Public Attributes | Friends | List of all members
DisplayAttrsMgrListDesc Class Reference

#include <RhinoSdkDisplayAttrsMgr.h>

Public Member Functions

 DisplayAttrsMgrListDesc ()
 
 DisplayAttrsMgrListDesc (const CDisplayPipelineAttributes &, bool bSupportsShadeCmd, bool bSupportsShading, bool bAddToMenu)
 
 DisplayAttrsMgrListDesc (const DisplayAttrsMgrListDesc &)
 
virtual ~DisplayAttrsMgrListDesc ()
 
const ON_UUIDDerivedFromId (void) const
 
bool GetBuiltInDefaults (DisplayAttrsMgrListDesc &)
 
void LoadProfile (const wchar_t *lpsSection, CRhinoProfileContext &)
 load from registry More...
 
void LoadProfile (const wchar_t *lpsSection, CRhinoProfileContext &, const DisplayAttrsMgrListDesc &defaults)
 load from registry More...
 
DisplayAttrsMgrListDescoperator= (const DisplayAttrsMgrListDesc &)
 
bool operator== (const DisplayAttrsMgrListDesc &) const
 
int Order (void) const
 
bool ReplaceAttributes (const ON_UUID &uuidAttributeClassId, bool bCopyExisting=false)
 
bool SaveProfile (const wchar_t *lpsSection, CRhinoProfileContext &) const
 save in registry More...
 

Static Public Member Functions

static bool BuiltInModeDefaults (int mode, DisplayAttrsMgrListDesc &dal)
 

Public Attributes

bool m_bAddToMenu
 
bool m_bAllowObjectAssignment
 
bool m_bPipelineLocked
 
bool m_bProfilePersistent
 
bool m_bShadedPipelineRequired
 
bool m_bSupportsShadeCmd
 
bool m_bSupportsShading
 
bool m_bSupportsStereo
 
bool m_bWireframePipelineRequired
 
CDisplayPipelineAttributesm_pAttrs
 

Friends

class COptionsAdvancedDisplay
 
class CRhinoDisplayAttrsMgr
 
class DisplayAttrsMgrList
 

Detailed Description

NoKeywords

/ / Copyright (c) 1993-2007 Robert McNeel & Associates. All rights reserved. / Rhinoceros is a registered trademark of Robert McNeel & Associates. / / THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. / ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF / MERCHANTABILITY ARE HEREBY DISCLAIMED. /
/ For complete Rhino SDK copyright information see http://www.rhino3d.com/developer. / ////////////////////////////////////////////////////////////// File: RhinoDisplayAttrsMgr.h – Interface file

Constructor & Destructor Documentation

◆ DisplayAttrsMgrListDesc() [1/3]

DisplayAttrsMgrListDesc::DisplayAttrsMgrListDesc ( )

◆ DisplayAttrsMgrListDesc() [2/3]

DisplayAttrsMgrListDesc::DisplayAttrsMgrListDesc ( const CDisplayPipelineAttributes ,
bool  bSupportsShadeCmd,
bool  bSupportsShading,
bool  bAddToMenu 
)

◆ DisplayAttrsMgrListDesc() [3/3]

DisplayAttrsMgrListDesc::DisplayAttrsMgrListDesc ( const DisplayAttrsMgrListDesc )

◆ ~DisplayAttrsMgrListDesc()

virtual DisplayAttrsMgrListDesc::~DisplayAttrsMgrListDesc ( )
virtual

Member Function Documentation

◆ BuiltInModeDefaults()

static bool DisplayAttrsMgrListDesc::BuiltInModeDefaults ( int  mode,
DisplayAttrsMgrListDesc dal 
)
static

◆ DerivedFromId()

const ON_UUID& DisplayAttrsMgrListDesc::DerivedFromId ( void  ) const
inline

◆ GetBuiltInDefaults()

bool DisplayAttrsMgrListDesc::GetBuiltInDefaults ( DisplayAttrsMgrListDesc )

◆ LoadProfile() [1/2]

void DisplayAttrsMgrListDesc::LoadProfile ( const wchar_t *  lpsSection,
CRhinoProfileContext  
)

load from registry

◆ LoadProfile() [2/2]

void DisplayAttrsMgrListDesc::LoadProfile ( const wchar_t *  lpsSection,
CRhinoProfileContext ,
const DisplayAttrsMgrListDesc defaults 
)

load from registry

◆ operator=()

DisplayAttrsMgrListDesc& DisplayAttrsMgrListDesc::operator= ( const DisplayAttrsMgrListDesc )

◆ operator==()

bool DisplayAttrsMgrListDesc::operator== ( const DisplayAttrsMgrListDesc ) const

◆ Order()

int DisplayAttrsMgrListDesc::Order ( void  ) const
inline

◆ ReplaceAttributes()

bool DisplayAttrsMgrListDesc::ReplaceAttributes ( const ON_UUID uuidAttributeClassId,
bool  bCopyExisting = false 
)

◆ SaveProfile()

bool DisplayAttrsMgrListDesc::SaveProfile ( const wchar_t *  lpsSection,
CRhinoProfileContext  
) const

save in registry

Friends And Related Function Documentation

◆ COptionsAdvancedDisplay

friend class COptionsAdvancedDisplay
friend

◆ CRhinoDisplayAttrsMgr

friend class CRhinoDisplayAttrsMgr
friend

◆ DisplayAttrsMgrList

friend class DisplayAttrsMgrList
friend

Member Data Documentation

◆ m_bAddToMenu

bool DisplayAttrsMgrListDesc::m_bAddToMenu

◆ m_bAllowObjectAssignment

bool DisplayAttrsMgrListDesc::m_bAllowObjectAssignment

◆ m_bPipelineLocked

bool DisplayAttrsMgrListDesc::m_bPipelineLocked

◆ m_bProfilePersistent

bool DisplayAttrsMgrListDesc::m_bProfilePersistent

◆ m_bShadedPipelineRequired

bool DisplayAttrsMgrListDesc::m_bShadedPipelineRequired

◆ m_bSupportsShadeCmd

bool DisplayAttrsMgrListDesc::m_bSupportsShadeCmd

◆ m_bSupportsShading

bool DisplayAttrsMgrListDesc::m_bSupportsShading

◆ m_bSupportsStereo

bool DisplayAttrsMgrListDesc::m_bSupportsStereo

◆ m_bWireframePipelineRequired

bool DisplayAttrsMgrListDesc::m_bWireframePipelineRequired

◆ m_pAttrs

CDisplayPipelineAttributes* DisplayAttrsMgrListDesc::m_pAttrs