#include <RhRdkSdkRender.h>
◆ ~IRhRdkAsyncRenderContext()
virtual IRhRdkAsyncRenderContext::~IRhRdkAsyncRenderContext |
( |
| ) |
|
|
inlinevirtual |
◆ DeleteThis()
virtual void IRhRdkAsyncRenderContext::DeleteThis |
( |
void |
| ) |
|
|
pure virtual |
You must implement this method as
◆ EVF()
virtual void* IRhRdkAsyncRenderContext::EVF |
( |
const wchar_t * |
, |
|
|
void * |
|
|
) |
| |
|
pure virtual |
Emergency virtual function for future expansion.
◆ OnQuietRenderFinished()
virtual void IRhRdkAsyncRenderContext::OnQuietRenderFinished |
( |
const IRhRdkRenderSession & |
session | ) |
|
|
pure virtual |
Implement this to be notified when a quiet rendering is finished.
◆ PauseRendering()
virtual void IRhRdkAsyncRenderContext::PauseRendering |
( |
void |
| ) |
|
|
pure virtual |
Implement this method to pause rendering.
◆ ResumeRendering()
virtual void IRhRdkAsyncRenderContext::ResumeRendering |
( |
void |
| ) |
|
|
pure virtual |
Implement this method to resume (i.e., un-pause) rendering.
◆ StopRendering()
virtual void IRhRdkAsyncRenderContext::StopRendering |
( |
void |
| ) |
|
|
pure virtual |
Called when RDK wants rendering to stop, for example when the user closes the window during rendering. You should stop rendering as soon as possible and only return when you are certain that your renderer will not attempt to access the render window again.
◆ SupportsPause()
virtual bool IRhRdkAsyncRenderContext::SupportsPause |
( |
void |
| ) |
const |
|
pure virtual |
Implement this method to return true if your renderer supports pause / resume, else false.