#include <IRhRdkRenderWindow.h>
|
enum | Status : unsigned int {
Status::Quiescent,
Status::Initializing,
Status::Rendering,
Status::Paused,
Status::Completed,
Status::Canceled,
Status::Aborted,
Status::Failed,
Status::Reusing,
Status::Disposed,
Status::Deleted,
Status::Waiting
} |
|
This is the interface to a render session.
- Note
- This interface is implemented in RDK in a thread-safe manner so that you can call the methods from any thread your renderer happens to be running in.
- See also
- CRhRdkRenderSession
-
CRhRdkSdkRenderImpl
-
IRhRdkAsyncRenderContext
-
IRhRdkRenderWindow
-
IRhRdkRenderUI
-
RhRdkFindRenderWindow
-
RhRdkFindRenderSession
◆ Status
Enumerator |
---|
Quiescent | |
Initializing | |
Rendering | |
Paused | |
Completed | |
Canceled | |
Aborted | |
Failed | |
Reusing | |
Disposed | |
Deleted | |
Waiting | |
◆ ~IRhRdkRenderSession()
virtual IRhRdkRenderSession::~IRhRdkRenderSession |
( |
| ) |
|
|
inlinevirtual |
◆ AsyncRenderContext()
- Returns
- The async render context if the render session is asynchronous, else null.
◆ BeginClone()
Create a clone of the render session. All important state is preserved in the clone except that it gets a new unique render session id. This call must be followed by a call to EndClone().
◆ Dispose()
virtual void IRhRdkRenderSession::Dispose |
( |
void |
| ) |
|
|
pure virtual |
Call this to dispose of the render session.
◆ ElapsedSeconds()
virtual int IRhRdkRenderSession::ElapsedSeconds |
( |
void |
| ) |
const |
|
pure virtual |
- Returns
- The number of seconds taken by rendering (so far if not finished).
◆ EndClone()
virtual void IRhRdkRenderSession::EndClone |
( |
void |
| ) |
const |
|
pure virtual |
Finish creating a clone of the render session.
◆ EVF()
virtual void* IRhRdkRenderSession::EVF |
( |
const wchar_t * |
, |
|
|
void * |
|
|
) |
| |
|
pure virtual |
Emergency virtual function for future expansion.
◆ GetPrevStatus()
virtual Status IRhRdkRenderSession::GetPrevStatus |
( |
void |
| ) |
const |
|
pure virtual |
◆ GetStatus()
virtual Status IRhRdkRenderSession::GetStatus |
( |
void |
| ) |
const |
|
pure virtual |
◆ IsLastRenderingValuable()
virtual bool IRhRdkRenderSession::IsLastRenderingValuable |
( |
void |
| ) |
const |
|
pure virtual |
- Returns
- true if the last rendering is considered 'valuable', else false. When closing valuable renderings, the user will be asked if s/he wants to save.
◆ RenderEngineId()
virtual UUID IRhRdkRenderSession::RenderEngineId |
( |
void |
| ) |
const |
|
pure virtual |
- Returns
- The render engine id of this render session.
◆ RenderSessionId()
virtual UUID IRhRdkRenderSession::RenderSessionId |
( |
void |
| ) |
const |
|
pure virtual |
- Returns
- The render session id of this render session.
◆ RenderWindow()
- Returns
- The render window associated with this render session.
◆ RhinoDocSerialNumber()
virtual unsigned int IRhRdkRenderSession::RhinoDocSerialNumber |
( |
void |
| ) |
const |
|
pure virtual |
- Returns
- The document serial number associated with this render session.
◆ SdkRender()
virtual class CRhRdkSdkRender* IRhRdkRenderSession::SdkRender |
( |
void |
| ) |
const |
|
pure virtual |
- Returns
- The SDK Render stack object associated with this render session.
- Note
- For async renderers, this method may return null because the SDK Render object goes off the stack right after rendering begins. It is not safe to call this method from your async rendering thread because the object may go off the stack and get deleted after the thread gets a pointer to it.
◆ SetAsyncRenderContext()
Set the async render context if the render session is asynchronous. RDK will take ownership of the async render context.
◆ SetElapsedSeconds()
virtual void IRhRdkRenderSession::SetElapsedSeconds |
( |
int |
elapsed | ) |
|
|
pure virtual |
◆ SetQuiet()
virtual void IRhRdkRenderSession::SetQuiet |
( |
void |
| ) |
|
|
pure virtual |
◆ SetStatus()
virtual void IRhRdkRenderSession::SetStatus |
( |
Status |
s | ) |
|
|
pure virtual |
◆ SetWasCanceled()
virtual void IRhRdkRenderSession::SetWasCanceled |
( |
void |
| ) |
|
|
pure virtual |
Set 'rendering was canceled' flag.
◆ StopRendering()
virtual void IRhRdkRenderSession::StopRendering |
( |
void |
| ) |
|
|
pure virtual |
Stop rendering as soon as possible. Should not return until rendering has stopped.
◆ WasCanceled()
virtual bool IRhRdkRenderSession::WasCanceled |
( |
void |
| ) |
const |
|
pure virtual |
Get 'rendering was canceled' flag.