Rhino C++ API
8.13
|
#include <IRhRdkContentEditor.h>
Public Types | |
enum | EditMethods : unsigned int { EditMethods::Local, EditMethods::Modal, EditMethods::Floating } |
Public Types inherited from IRhRdkEditor | |
enum | Types : unsigned int { Types::Unset, Types::Main, Types::Modal, Types::Floating, Types::InPlace } |
Public Member Functions | |
virtual | ~IRhRdkContentEditor () |
virtual RDK_INTERNAL CRhRdkControllerPtr | Controller (void) const =0 |
virtual void * | EVF (const wchar_t *, void *)=0 |
virtual void | OnContentUICreated (class IRhRdkContentUI &ui)=0 |
virtual_su UUID | RdkDocumentId (void) const |
virtual_su void | SetRdkDocumentId (const UUID &uuidRdkDoc) |
virtual CRhRdkContent::Kinds | TopLevelKind (void) const =0 |
virtual RDK_DEPRECATED HWND | UiHostWindow (void) const =0 |
Public Member Functions inherited from IRhRdkEditor | |
virtual RhRdkUiFrameworks | Framework (void) const =0 |
virtual UUID | Id (void) const =0 |
virtual RhRdkUiModalities | Modality (void) const =0 |
virtual Types | Type (void) const =0 |
Static Public Member Functions | |
static IRhRdkContentEditor * | Find (const UUID &uuidEditor) |
Static Public Member Functions inherited from IRhRdkEditor | |
static RDK_DEPRECATED IRhRdkEditor * | Find (const UUID &uuidEditor) |
Additional Inherited Members | |
Protected Member Functions inherited from IRhRdkEditor | |
virtual | ~IRhRdkEditor () |
This interface represents a content editor. Currently two types of content editor are implemented:
A content editor acts as a host for a content UI. The UiHostWindow() method returns a pointer to the window that is the parent of the main UI window. The main UI window is usually a content UI holder containing sections (AKA roll-ups), but if you override CRhRdkCoreContent::CreateUI() and provide a custom UI, it can be anything you like.
A content editor must know the document it is for. This is not strictly needed on Windows, but on the Mac there can be many editors for a content kind but each for a different document. Even modal editors which are capable of editing free-floating contents still have a document, but this document is a 'sandbox', not a 'live' document.
|
strong |
|
inlinevirtual |
|
pure virtual |
|
pure virtual |
Emergency virtual function for future expansion.
Implements IRhRdkEditor.
|
static |
Find a content editor by its id.
|
pure virtual |
Called just after a content UI has been created.
virtual_su UUID IRhRdkContentEditor::RdkDocumentId | ( | void | ) | const |
virtual_su void IRhRdkContentEditor::SetRdkDocumentId | ( | const UUID & | uuidRdkDoc | ) |
|
pure virtual |
|
pure virtual |
OBSOLETE. There is no longer a host 'window' since the framework uses Eto (which is C#). If you were calling this, just use NULL for the host or parent.