Rhino C++ API  8.5
Public Member Functions | Static Public Member Functions | Protected Member Functions | List of all members
IRhRdkContentUI Class Referenceabstract

#include <IRhRdkContentUI.h>

Inheritance diagram for IRhRdkContentUI:
CRhRdkCustomContentUI IRhRdkExpandableContentUI

Public Member Functions

virtual void AddClient (const CRhRdkContent &c)=0
 
RDK_DEPRECATED void AddClient (CRhRdkCoreContent &c)
 
virtual RDK_DEPRECATED void AddSection (class CRhRdkExpandingSection *pSection, int dummy=0)
 
virtual int ClientCount (void) const =0
 
virtual IRhinoUiHolderContentUIHolder (void) const =0
 
virtual CRhRdkControllerPtr Controller (void) const =0
 
virtual ON_wString DebugString (void) const =0
 
virtual void DeleteThis (void)=0
 
virtual void Destroy (void)=0
 
virtual void DisplayData (void)=0
 
virtual UUID EditorUuid (void) const =0
 
virtual void Enable (bool bEnable)=0
 
virtual void EnableDisableControls (void)=0
 
virtual void * EVF (const wchar_t *, void *)=0
 
virtual RhRdkUiFrameworks Framework (void) const =0
 
virtual RDK_DEPRECATED class IRhinoUiHolderHolder (void) const
 
virtual bool IsCreated (void) const =0
 
virtual bool IsShown (void) const =0
 
virtual void ReleaseAllClients (void)=0
 
virtual void RemClient (const CRhRdkContent &c)=0
 
RDK_DEPRECATED void RemClient (CRhRdkCoreContent &c)
 
virtual void SetController (CRhRdkControllerPtr con)=0
 
virtual void SetPositionAndSize (const ON_4iRect &rect)=0
 
virtual void SetSelection (const CRhRdkContentArray &aContent)=0
 
virtual void Show (bool bShow)=0
 
virtual UUID Uuid (void) const =0
 

Static Public Member Functions

static RDK_DEPRECATED IRhRdkContentUIGet (const UUID &)
 

Protected Member Functions

virtual ~IRhRdkContentUI ()
 

Detailed Description

This interface represents the user interface (UI) of a content. A content's UI appears inside an editor which is represented by IRhRdkContentEditor. The UI is the part of the editor which allows the user to view and modify the persistent state of the selected content(s).

This interface is implemented by RDK internally in the core content class, CRhRdkCoreContent. If you do not override CRhRdkCoreContent::CreateUI() you do not have to concern yourself with the details. If however, you do want to override CreateUI() to create your own custom UI, then you must derive your UI class from CRhRdkCustomContentUI and implement this interface to support your own UI design.

Note
CRhRdkCustomContentUI implements some of this interface for you.
See also
CRhRdkCustomContentUI
CRhRdkContent::CreateUI()
CRhRdkCoreContent::CreateUI()
IRhRdkContentEditor

Constructor & Destructor Documentation

◆ ~IRhRdkContentUI()

virtual IRhRdkContentUI::~IRhRdkContentUI ( )
inlineprotectedvirtual

Member Function Documentation

◆ AddClient() [1/2]

virtual void IRhRdkContentUI::AddClient ( const CRhRdkContent c)
pure virtual

Called when a client is added to the UI. Your implementation should remember this client, perhaps in a CRhRdkContentArray. Implemented by CRhRdkCustomContentUI.

See also
ClientCount()

Implemented in CRhRdkCustomContentUI.

◆ AddClient() [2/2]

RDK_DEPRECATED void IRhRdkContentUI::AddClient ( CRhRdkCoreContent c)

This method is deprecated in favor of the one below.

◆ AddSection()

virtual RDK_DEPRECATED void IRhRdkContentUI::AddSection ( class CRhRdkExpandingSection *  pSection,
int  dummy = 0 
)
virtual

This method is deprecated (not implemented) because IRhRdkContentUI can now be implemented without using any 'sections'. This happens in custom UIs. You will need to change your code to add the section via IRhRdkExpandableContentUI.

◆ ClientCount()

virtual int IRhRdkContentUI::ClientCount ( void  ) const
pure virtual
Returns
the number of clients using the UI. Implemented by CRhRdkCustomContentUI.
See also
AddClient()
RemClient()

Implemented in CRhRdkCustomContentUI.

◆ ContentUIHolder()

virtual IRhinoUiHolder* IRhRdkContentUI::ContentUIHolder ( void  ) const
pure virtual
Returns
The holder that contains the UI sections, if this is an expandable content UI with sections inside holders. Returns null for custom UIs.

Implemented in CRhRdkCustomContentUI, and IRhRdkExpandableContentUI.

◆ Controller()

virtual CRhRdkControllerPtr IRhRdkContentUI::Controller ( void  ) const
pure virtual
Returns
the UI's controller.

Implemented in CRhRdkCustomContentUI.

◆ DebugString()

virtual ON_wString IRhRdkContentUI::DebugString ( void  ) const
pure virtual
Returns
UI information for debugging.

Implemented in CRhRdkCustomContentUI.

◆ DeleteThis()

virtual void IRhRdkContentUI::DeleteThis ( void  )
pure virtual

You must implement this method as

delete this;

◆ Destroy()

virtual void IRhRdkContentUI::Destroy ( void  )
pure virtual

Your implementation must do any and all clean-up here and not in DeleteThis().

◆ DisplayData()

virtual void IRhRdkContentUI::DisplayData ( void  )
pure virtual

Called when the UI should transfer the selected content state to the controls.

See also
SetSelection().

◆ EditorUuid()

virtual UUID IRhRdkContentUI::EditorUuid ( void  ) const
pure virtual

Get the unique identifier of the editor that the UI is being displayed in. Implemented by CRhRdkCustomContentUI.

Implemented in CRhRdkCustomContentUI.

◆ Enable()

virtual void IRhRdkContentUI::Enable ( bool  bEnable)
pure virtual

Enable/disable the UI. Your implementation must respond to this by enabling or disabling the entire UI.

◆ EnableDisableControls()

virtual void IRhRdkContentUI::EnableDisableControls ( void  )
pure virtual

Enable or disable controls in the UI.

◆ EVF()

virtual void* IRhRdkContentUI::EVF ( const wchar_t *  ,
void *   
)
pure virtual

Emergency virtual function for future expansion.

Implemented in CRhRdkCustomContentUI.

◆ Framework()

virtual RhRdkUiFrameworks IRhRdkContentUI::Framework ( void  ) const
pure virtual
Returns
the UI's framework.

◆ Get()

static RDK_DEPRECATED IRhRdkContentUI* IRhRdkContentUI::Get ( const UUID &  )
inlinestatic

This method is deprecated (not implemented) in favor of RhRdkContentUIManager().FindUI()

◆ Holder()

virtual RDK_DEPRECATED class IRhinoUiHolder& IRhRdkContentUI::Holder ( void  ) const
virtual

This method is deprecated (not implemented) because IRhRdkContentUI can now be implemented without using any 'holder'. This happens in custom UIs.

◆ IsCreated()

virtual bool IRhRdkContentUI::IsCreated ( void  ) const
pure virtual
Returns
true if the UI is created else false.

◆ IsShown()

virtual bool IRhRdkContentUI::IsShown ( void  ) const
pure virtual
Returns
true if the UI is being shown, else false.

◆ ReleaseAllClients()

virtual void IRhRdkContentUI::ReleaseAllClients ( void  )
pure virtual

Implemented in CRhRdkCustomContentUI.

◆ RemClient() [1/2]

virtual void IRhRdkContentUI::RemClient ( const CRhRdkContent c)
pure virtual

Called when a client is removed from the UI. Your implementation should remove the client from its client list or array. When the last client is removed, you must hide the entire UI. Implemented by CRhRdkCustomContentUI.

See also
ClientCount().

Implemented in CRhRdkCustomContentUI.

◆ RemClient() [2/2]

RDK_DEPRECATED void IRhRdkContentUI::RemClient ( CRhRdkCoreContent c)

This method is deprecated in favor of the one below.

◆ SetController()

virtual void IRhRdkContentUI::SetController ( CRhRdkControllerPtr  con)
pure virtual

Set the UI's controller.

Implemented in CRhRdkCustomContentUI.

◆ SetPositionAndSize()

virtual void IRhRdkContentUI::SetPositionAndSize ( const ON_4iRect rect)
pure virtual

Set the position and size of the UI.

◆ SetSelection()

virtual void IRhRdkContentUI::SetSelection ( const CRhRdkContentArray aContent)
pure virtual

Called when the user selects content in the editor.

Parameters
aContentis the content being selected. Your UI should 'remember' the instance ids of the contents so that it can look them up again and transfer their state to the controls in DisplayData().
See also
DisplayData().

Implemented in CRhRdkCustomContentUI.

◆ Show()

virtual void IRhRdkContentUI::Show ( bool  bShow)
pure virtual

Show/Hide the UI. Your implementation must respond to this by showing or hiding the entire UI. Please call the base class.

Implemented in CRhRdkCustomContentUI.

◆ Uuid()

virtual UUID IRhRdkContentUI::Uuid ( void  ) const
pure virtual

Get the unique identifier of the UI. Implemented by CRhRdkCustomContentUI.

Implemented in CRhRdkCustomContentUI.