Rhino C++ API  8.6
Public Member Functions | Protected Member Functions | List of all members
IRhRdkCustomCurveGraphSectionSharedCallback Class Referenceabstract

#include <RhRdkCurveGraph.h>

Public Member Functions

virtual void DeleteThis (void)=0
 
virtual void * EVF (const wchar_t *wszFunc, void *pvData)=0
 
virtual void GetGraphXML (const CRhRdkContentArray &aSelection, OUT ON_wString &sXML) const =0
 
virtual bool IsSectionHidden (const CRhRdkContentArray &aSelection) const =0
 
virtual void OnGraphChanged (const CRhRdkContentArray &aSelection, const ON_wString &sXML)=0
 
virtual IRhRdkCustomCurveCtrl::Styles Style (void) const =0
 

Protected Member Functions

virtual ~IRhRdkCustomCurveGraphSectionSharedCallback ()
 

Constructor & Destructor Documentation

◆ ~IRhRdkCustomCurveGraphSectionSharedCallback()

virtual IRhRdkCustomCurveGraphSectionSharedCallback::~IRhRdkCustomCurveGraphSectionSharedCallback ( )
inlineprotectedvirtual

Member Function Documentation

◆ DeleteThis()

virtual void IRhRdkCustomCurveGraphSectionSharedCallback::DeleteThis ( void  )
pure virtual

Implement this method as

delete this

.

◆ EVF()

virtual void* IRhRdkCustomCurveGraphSectionSharedCallback::EVF ( const wchar_t *  wszFunc,
void *  pvData 
)
pure virtual

Emergency virtual function for future expansion.

◆ GetGraphXML()

virtual void IRhRdkCustomCurveGraphSectionSharedCallback::GetGraphXML ( const CRhRdkContentArray aSelection,
OUT ON_wString sXML 
) const
pure virtual

Implement this method to load the graph XML into sXML.

◆ IsSectionHidden()

virtual bool IRhRdkCustomCurveGraphSectionSharedCallback::IsSectionHidden ( const CRhRdkContentArray aSelection) const
pure virtual

Implement this method to return true if the custom curve section should be hidden.

◆ OnGraphChanged()

virtual void IRhRdkCustomCurveGraphSectionSharedCallback::OnGraphChanged ( const CRhRdkContentArray aSelection,
const ON_wString sXML 
)
pure virtual

Implement this method to perform required actions when the user changes the graph.

Parameters
sXMLcontains the graph XML after the change.

◆ Style()

virtual IRhRdkCustomCurveCtrl::Styles IRhRdkCustomCurveGraphSectionSharedCallback::Style ( void  ) const
pure virtual

Implement this method to return the style of the graph.