Rhino C++ API  8.6
Classes | Public Types | Public Member Functions | Static Public Member Functions | Protected Member Functions | List of all members
IRhRdkCustomCurveCtrl Class Referenceabstract

#include <RhRdkCurveGraph.h>

Inheritance diagram for IRhRdkCustomCurveCtrl:
IRhinoUiWindow

Classes

class  IPoint
 

Public Types

enum  NotificationContexts : unsigned int { NotificationContexts::Points, NotificationContexts::Cursor, NotificationContexts::Menu, NotificationContexts::PtDblClick }
 Notification contexts. More...
 
enum  ScaleModes : unsigned int { ScaleModes::Bounds, ScaleModes::Constraints, ScaleModes::Display }
 Scale modes. More...
 
enum  Styles : unsigned int { Styles::Gray, Styles::RGB, Styles::RGBA }
 Styles. More...
 
enum  TextModes : unsigned int { TextModes::Always, TextModes::WhenSelected, TextModes::WhenOneSelected, TextModes::Never }
 Text modes. More...
 

Public Member Functions

virtual void AddPoint (int iCurve, double x, double y, double dTanX, double dTanY, bool bSelect)=0
 
virtual void AddPoints (double x, double y, double dTanX, double dTanY, bool bSelect)=0
 
virtual void ConstraintsX (double &dMinOut, double &dMaxOut) const =0
 
virtual void ConstraintsY (double &dMinOut, double &dMaxOut) const =0
 
virtual int CountSelection (bool bIncludeTanPoints) const =0
 
virtual bool CursorOn (void) const =0
 
virtual double CursorPosition (void) const =0
 
virtual void DeleteSelectedPoints (void)=0
 
virtual double DisplayMax (void) const =0
 
virtual double DisplayMin (void) const =0
 
virtual void DoAutoScaling (bool bAnimate=true, bool bForce=false, bool bScaleX=true, bool bScaleY=true)=0
 
virtual bool DragZoomingOn (void) const =0
 
virtual CPoint GraphToPixel (double x, double y) const =0
 
virtual bool GridFrequencyOn (void) const =0
 
virtual ON_Color InnerColor (void) const =0
 
virtual void InvertSelection (bool bIncludeTanPoints)=0
 
virtual void MoveSelectedPoints (int dx, int dy)=0
 
virtual bool MultiSelect (void) const =0
 
virtual ON_Color OuterColor (void) const =0
 
virtual ON_2dPoint PixelToGraph (int x, int y) const =0
 
virtual ON_Color PointColor (void) const =0
 
virtual int PointPickMargin (void) const =0
 
virtual ON_Color PointSelectedColor (void) const =0
 
virtual int PointSize (void) const =0
 
virtual double PointSnapX (void) const =0
 
virtual double PointSnapY (void) const =0
 
virtual void Reset (void)=0
 
virtual void ResetAxes (double dScaleX=1.0, double dScaleY=1.0)=0
 
virtual bool RulerOn (void) const =0
 
virtual ScaleModes ScaleModeX (void) const =0
 
virtual ScaleModes ScaleModeY (void) const =0
 
virtual void SelectAllPoints (bool bIncludeTanPoints)=0
 
virtual void SetAutoScalingParams (int iDelay, int iSteps)=0
 
virtual void SetConstraintsX (double dMin, double dMax)=0
 
virtual void SetConstraintsY (double dMin, double dMax)=0
 
virtual void SetCursorOn (bool bOn)=0
 
virtual void SetCursorPosition (double d)=0
 
virtual void SetDisplayMax (double d)=0
 
virtual void SetDisplayMin (double d)=0
 
virtual void SetDragZoomingOn (bool bOn)=0
 
virtual void SetGridFrequencies (double dMajorFreqX, double dMinorFreqX, double dMicroFreqX, double dMajorFreqY, double dMinorFreqY, double dMicroFreqY)=0
 
virtual void SetGridFrequencyOn (bool bOn)=0
 
virtual void SetInnerColor (const ON_Color &col)=0
 
virtual void SetMargins (int l, int t, int r, int b)=0
 
virtual void SetMultiSelect (bool bMultiSelect)=0
 
virtual void SetNotificationHandler (IRhRdkNotificationHandler *pNH)=0
 
virtual void SetOuterColor (const ON_Color &col)=0
 
virtual void SetPointColor (const ON_Color &col)=0
 
virtual void SetPointPickMargin (int iMargin)=0
 
virtual void SetPointSelectedColor (const ON_Color &col)=0
 
virtual void SetPointSize (int iSize)=0
 
virtual void SetPointSnapX (double dSnap)=0
 
virtual void SetPointSnapY (double dSnap)=0
 
virtual void SetRulerColors (const ON_Color &colInt, const ON_Color &colFrac)=0
 
virtual void SetRulerOn (bool bOn)=0
 
virtual void SetScaleModeX (ScaleModes m)=0
 
virtual void SetScaleModeY (ScaleModes m)=0
 
virtual void SetShadeConstraints (bool bOn)=0
 
virtual void SetTangentColor (const ON_Color &col)=0
 
virtual void SetTangentScale (double d)=0
 
virtual void SetTangentSnapToAngle (double dAngle)=0
 
virtual void SetTextColor (const ON_Color &col)=0
 
virtual void SetTextMode (TextModes m)=0
 
virtual void SetUseAutoScaling (bool bOn)=0
 
virtual bool ShadeConstraints (void) const =0
 
virtual Styles Style (void) const =0
 
virtual ON_Color TangentColor (void) const =0
 
virtual double TangentScale (void) const =0
 
virtual double TangentSnapToAngle (void) const =0
 
virtual ON_Color TextColor (void) const =0
 
virtual TextModes TextMode (void) const =0
 
virtual void UnselectAllPoints (bool bIncludeTanPoints)=0
 
virtual bool UseAutoScaling (void) const =0
 
virtual void ZoomToExtents (void)=0
 
virtual void ZoomToGraphRect (const ON_2dPoint &pt1, const ON_2dPoint &pt2)=0
 
virtual void ZoomToPixelRect (const ON_4iRect &rect)=0
 
- Public Member Functions inherited from IRhinoUiWindow
virtual ON_wString Caption (bool bAlwaysEnglish=false) const =0
 
virtual void Delete (void)=0
 
virtual void Enable (bool bEnable)=0
 
virtual void * EVF (const wchar_t *wszFunc, void *pvData)=0
 
virtual void GetScreenCoords (ON_4iRect &rectOut) const =0
 
virtual HWND GetWindow (void)=0
 
virtual bool IsCreated (void) const =0
 
virtual bool IsEnabled (void) const =0
 
virtual bool IsShown (void) const =0
 
virtual void Move (const ON_4iRect &rect, bool bRepaint=false, bool bRepaintBorder=false)=0
 
virtual HWND Parent (void) const =0
 
virtual void Refresh (bool bImmediate=false)=0
 
virtual void SetFocus (void)=0
 
virtual void SetParent (HWND parent)=0
 
virtual void Show (bool bShow)=0
 

Static Public Member Functions

static IRhRdkCustomCurveCtrlNew (Styles style, RhRdkUiFrameworks f)
 

Protected Member Functions

virtual ~IRhRdkCustomCurveCtrl ()
 
- Protected Member Functions inherited from IRhinoUiWindow
virtual ~IRhinoUiWindow ()
 

Member Enumeration Documentation

◆ NotificationContexts

enum IRhRdkCustomCurveCtrl::NotificationContexts : unsigned int
strong

Notification contexts.

Enumerator
Points 

Notification is about point(s).

Cursor 

Notification is about cursor.

Menu 

Notification is about context menu.

PtDblClick 

Notification is about point(s) being double-clicked.

◆ ScaleModes

enum IRhRdkCustomCurveCtrl::ScaleModes : unsigned int
strong

Scale modes.

Enumerator
Bounds 

Graph is automatically scaled to fit min/max bounds of all points.

Constraints 

Graph is automatically scaled to constraints.

Display 

Graph is automatically scaled to display min/max.

◆ Styles

enum IRhRdkCustomCurveCtrl::Styles : unsigned int
strong

Styles.

Enumerator
Gray 

Single gray curve.

RGB 

Red, green and blue curve.

RGBA 

Red, green, blue and alpha curves.

◆ TextModes

enum IRhRdkCustomCurveCtrl::TextModes : unsigned int
strong

Text modes.

Enumerator
Always 

Text is always displayed.

WhenSelected 

Text is only displayed when point is selected.

WhenOneSelected 

Text is only displayed when point is the only selected point.

Never 

Text is never displayed.

Constructor & Destructor Documentation

◆ ~IRhRdkCustomCurveCtrl()

virtual IRhRdkCustomCurveCtrl::~IRhRdkCustomCurveCtrl ( )
inlineprotectedvirtual

Member Function Documentation

◆ AddPoint()

virtual void IRhRdkCustomCurveCtrl::AddPoint ( int  iCurve,
double  x,
double  y,
double  dTanX,
double  dTanY,
bool  bSelect 
)
pure virtual

Adds a point to a curve.

◆ AddPoints()

virtual void IRhRdkCustomCurveCtrl::AddPoints ( double  x,
double  y,
double  dTanX,
double  dTanY,
bool  bSelect 
)
pure virtual

Adds a point to each curve in the control.

◆ ConstraintsX()

virtual void IRhRdkCustomCurveCtrl::ConstraintsX ( double &  dMinOut,
double &  dMaxOut 
) const
pure virtual

Get the min/max X constraint values used when the X scale mode is 'constraints'.

Note
Points are always constrained to constraints, regardless of the scale mode.
See also
MoveSelectedPoints().

◆ ConstraintsY()

virtual void IRhRdkCustomCurveCtrl::ConstraintsY ( double &  dMinOut,
double &  dMaxOut 
) const
pure virtual

Get the min/max Y constraint values used when the Y scale mode is 'constraints'.

Note
Points are always constrained to constraints, regardless of the scale mode.
See also
MoveSelectedPoints().

◆ CountSelection()

virtual int IRhRdkCustomCurveCtrl::CountSelection ( bool  bIncludeTanPoints) const
pure virtual

Count how many points are selected on all the curves.

Parameters
bIncludeTanPointsindicates if tangent points should also be counted.

◆ CursorOn()

virtual bool IRhRdkCustomCurveCtrl::CursorOn ( void  ) const
pure virtual

Report if the cursor is on or off.

◆ CursorPosition()

virtual double IRhRdkCustomCurveCtrl::CursorPosition ( void  ) const
pure virtual

Get the cursor position.

◆ DeleteSelectedPoints()

virtual void IRhRdkCustomCurveCtrl::DeleteSelectedPoints ( void  )
pure virtual

Delete all the selected points from all the curves.

◆ DisplayMax()

virtual double IRhRdkCustomCurveCtrl::DisplayMax ( void  ) const
pure virtual

Get the max X display value used when the X scale mode is 'display'.

◆ DisplayMin()

virtual double IRhRdkCustomCurveCtrl::DisplayMin ( void  ) const
pure virtual

Get the min X display value used when the X scale mode is 'display'.

◆ DoAutoScaling()

virtual void IRhRdkCustomCurveCtrl::DoAutoScaling ( bool  bAnimate = true,
bool  bForce = false,
bool  bScaleX = true,
bool  bScaleY = true 
)
pure virtual

Ask display to automatically scale.

Parameters
bAnimateif true, the scaling is animated.
bForceif true, the method works even if auto-scaling is disabled.
bScaleXis to include scaling in X.
bScaleYis to include scaling in Y.

◆ DragZoomingOn()

virtual bool IRhRdkCustomCurveCtrl::DragZoomingOn ( void  ) const
pure virtual

Get whether drag-zooming mode is on or off.

◆ GraphToPixel()

virtual CPoint IRhRdkCustomCurveCtrl::GraphToPixel ( double  x,
double  y 
) const
pure virtual

Convert graph coordinates to client area pixel coordinates.

◆ GridFrequencyOn()

virtual bool IRhRdkCustomCurveCtrl::GridFrequencyOn ( void  ) const
pure virtual
Returns
true if the fixed grid frequency option is on.

◆ InnerColor()

virtual ON_Color IRhRdkCustomCurveCtrl::InnerColor ( void  ) const
pure virtual

Get the color of the graph's interior.

◆ InvertSelection()

virtual void IRhRdkCustomCurveCtrl::InvertSelection ( bool  bIncludeTanPoints)
pure virtual

Invert the selection on all enabled curves.

Parameters
bIncludeTanPointsindicates if tangent points should also be affected.

◆ MoveSelectedPoints()

virtual void IRhRdkCustomCurveCtrl::MoveSelectedPoints ( int  dx,
int  dy 
)
pure virtual

Move all the selected points on all the curves by a pixel offset. If snap-to-grid is on, points will be snapped to the grid.

See also
PointSnapX(). If the scale mode is 'constraints' for any axis, that axis' movement is limited by its constraint values.
ScaleMode().

◆ MultiSelect()

virtual bool IRhRdkCustomCurveCtrl::MultiSelect ( void  ) const
pure virtual
Returns
The multi-select state of the curve control.

◆ New()

static IRhRdkCustomCurveCtrl* IRhRdkCustomCurveCtrl::New ( Styles  style,
RhRdkUiFrameworks  f 
)
static

STARTING WITH RHINO 8, THIS CONTROL IS DEPRECATED AND DOES NOT WORK. See [DEPCTL]

Returns
null

◆ OuterColor()

virtual ON_Color IRhRdkCustomCurveCtrl::OuterColor ( void  ) const
pure virtual

Get the color of the graph's exterior border.

◆ PixelToGraph()

virtual ON_2dPoint IRhRdkCustomCurveCtrl::PixelToGraph ( int  x,
int  y 
) const
pure virtual

Convert client area pixel coordinates to graph coordinates.

◆ PointColor()

virtual ON_Color IRhRdkCustomCurveCtrl::PointColor ( void  ) const
pure virtual

Get the color of an unselected curve point for all curves.

◆ PointPickMargin()

virtual int IRhRdkCustomCurveCtrl::PointPickMargin ( void  ) const
pure virtual
Returns
The pick margin of a selectable point. This is measured in pixels; it allows easier picking of small points.

◆ PointSelectedColor()

virtual ON_Color IRhRdkCustomCurveCtrl::PointSelectedColor ( void  ) const
pure virtual

Get the color of a selected curve point for all curves.

◆ PointSize()

virtual int IRhRdkCustomCurveCtrl::PointSize ( void  ) const
pure virtual
Returns
The point size of a selectable point. This is measured in pixels and is about half the width or height of the point. Points are square.

◆ PointSnapX()

virtual double IRhRdkCustomCurveCtrl::PointSnapX ( void  ) const
pure virtual
Returns
The resolution for point snap-to-grid in X.

◆ PointSnapY()

virtual double IRhRdkCustomCurveCtrl::PointSnapY ( void  ) const
pure virtual
Returns
The resolution for point snap-to-grid in Y.

◆ Reset()

virtual void IRhRdkCustomCurveCtrl::Reset ( void  )
pure virtual

Resets the control to factory defaults.

◆ ResetAxes()

virtual void IRhRdkCustomCurveCtrl::ResetAxes ( double  dScaleX = 1.0,
double  dScaleY = 1.0 
)
pure virtual

Reset the scale and origin of the axes to their factory settings. Change scale values to < 1 to show axes even when no curves are present.

◆ RulerOn()

virtual bool IRhRdkCustomCurveCtrl::RulerOn ( void  ) const
pure virtual

Report if the ruler is on or off.

◆ ScaleModeX()

virtual ScaleModes IRhRdkCustomCurveCtrl::ScaleModeX ( void  ) const
pure virtual

Get the X scale mode.

See also
MoveSelectedPoints().

◆ ScaleModeY()

virtual ScaleModes IRhRdkCustomCurveCtrl::ScaleModeY ( void  ) const
pure virtual

Get the Y scale mode.

See also
MoveSelectedPoints().

◆ SelectAllPoints()

virtual void IRhRdkCustomCurveCtrl::SelectAllPoints ( bool  bIncludeTanPoints)
pure virtual

Select all the points on all the curves.

Parameters
bIncludeTanPointsindicates if tangent points should also be selected.

◆ SetAutoScalingParams()

virtual void IRhRdkCustomCurveCtrl::SetAutoScalingParams ( int  iDelay,
int  iSteps 
)
pure virtual

Set auto-scaling animation parameters. Only used if auto-scaling is enabled.

Parameters
iDelayis the animation delay in milliseconds. Use zero to disable animation.
iStepsis the number of animation steps.

◆ SetConstraintsX()

virtual void IRhRdkCustomCurveCtrl::SetConstraintsX ( double  dMin,
double  dMax 
)
pure virtual

Set the min/max X constraint values used when the X scale mode is 'constraints'.

Note
Points are always constrained to constraints, regardless of the scale mode. To disable a constraint, use the value cdNoConstraint.
See also
MoveSelectedPoints().

◆ SetConstraintsY()

virtual void IRhRdkCustomCurveCtrl::SetConstraintsY ( double  dMin,
double  dMax 
)
pure virtual

Set the min/max Y constraint values used when the Y scale mode is 'constraints'.

Note
Points are always constrained to constraints, regardless of the scale mode. To disable a constraint, use the value cdNoConstraint.
See also
MoveSelectedPoints().

◆ SetCursorOn()

virtual void IRhRdkCustomCurveCtrl::SetCursorOn ( bool  bOn)
pure virtual

Set the cursor on or off.

◆ SetCursorPosition()

virtual void IRhRdkCustomCurveCtrl::SetCursorPosition ( double  d)
pure virtual

Set the cursor position.

◆ SetDisplayMax()

virtual void IRhRdkCustomCurveCtrl::SetDisplayMax ( double  d)
pure virtual

Set the max X display value used when the X scale mode is 'display'.

◆ SetDisplayMin()

virtual void IRhRdkCustomCurveCtrl::SetDisplayMin ( double  d)
pure virtual

Set the min X display value used when the X scale mode is 'display'.

◆ SetDragZoomingOn()

virtual void IRhRdkCustomCurveCtrl::SetDragZoomingOn ( bool  bOn)
pure virtual

Set drag-zooming mode on or off.

◆ SetGridFrequencies()

virtual void IRhRdkCustomCurveCtrl::SetGridFrequencies ( double  dMajorFreqX,
double  dMinorFreqX,
double  dMicroFreqX,
double  dMajorFreqY,
double  dMinorFreqY,
double  dMicroFreqY 
)
pure virtual

Set the frequency of the major and minor grids in each axis. The defaults are major=1.0 and minor=0.1.

Parameters
dMajorFreqXsets the frequency of the x-axis major grid. Use zero to disable this grid.
dMinorFreqXsets the frequency of the x-axis minor grid. Use zero to disable this grid.
dMicroFreqXsets the frequency of the x-axis micro grid. Use zero to disable this grid.
dMajorFreqYsets the frequency of the y-axis major grid. Use zero to disable this grid.
dMinorFreqYsets the frequency of the y-axis minor grid. Use zero to disable this grid.
dMicroFreqYsets the frequency of the y-axis micro grid. Use zero to disable this grid.
Note
These settings are only used after SetGridFrequencyOn(true) has been called.

◆ SetGridFrequencyOn()

virtual void IRhRdkCustomCurveCtrl::SetGridFrequencyOn ( bool  bOn)
pure virtual

By default, the grid looks nice and shows zooming but has no real meaning. Use this method to switch the grid to show a fixed frequency instead.

See also
SetGridFrequencies()

◆ SetInnerColor()

virtual void IRhRdkCustomCurveCtrl::SetInnerColor ( const ON_Color col)
pure virtual

OBSOLETE.

◆ SetMargins()

virtual void IRhRdkCustomCurveCtrl::SetMargins ( int  l,
int  t,
int  r,
int  b 
)
pure virtual

Set the margins between the inner graph and the outer window frame.

◆ SetMultiSelect()

virtual void IRhRdkCustomCurveCtrl::SetMultiSelect ( bool  bMultiSelect)
pure virtual

Set the multi-select state of the curve. If true, multiple overlapping points on different curves will be selected with a single mouse click.

◆ SetNotificationHandler()

virtual void IRhRdkCustomCurveCtrl::SetNotificationHandler ( IRhRdkNotificationHandler pNH)
pure virtual

Set a notification handler. RDK takes ownership of the object. When IRhRdkNotificationHandler::OnNotify(), OnBeginNotify() or OnEndNotify() are called, the type of the vOld and vNew variants will be as follows:

  • If 'context' is Points : pointer; must be cast to ON_SimpleArray<IPoint*>*
  • If 'context' is Cursor : double; old and new cursor positions.
  • If 'context' is Menu : vOld is null, vNew is 2D vector (mouse position).
  • If 'context' is PtDblClick : vOld is null, vNew is pointer; must be cast to IPoint*

◆ SetOuterColor()

virtual void IRhRdkCustomCurveCtrl::SetOuterColor ( const ON_Color col)
pure virtual

OBSOLETE.

◆ SetPointColor()

virtual void IRhRdkCustomCurveCtrl::SetPointColor ( const ON_Color col)
pure virtual

OBSOLETE.

◆ SetPointPickMargin()

virtual void IRhRdkCustomCurveCtrl::SetPointPickMargin ( int  iMargin)
pure virtual

Set the pick margin of a selectable point.

◆ SetPointSelectedColor()

virtual void IRhRdkCustomCurveCtrl::SetPointSelectedColor ( const ON_Color col)
pure virtual

OBSOLETE.

◆ SetPointSize()

virtual void IRhRdkCustomCurveCtrl::SetPointSize ( int  iSize)
pure virtual

Set the point size of a selectable point.

◆ SetPointSnapX()

virtual void IRhRdkCustomCurveCtrl::SetPointSnapX ( double  dSnap)
pure virtual

Set the resolution for point snap-to-grid in X. Use zero to disable snap-to-grid in X.

◆ SetPointSnapY()

virtual void IRhRdkCustomCurveCtrl::SetPointSnapY ( double  dSnap)
pure virtual

Set the resolution for point snap-to-grid in Y. Use zero to disable snap-to-grid in Y.

◆ SetRulerColors()

virtual void IRhRdkCustomCurveCtrl::SetRulerColors ( const ON_Color colInt,
const ON_Color colFrac 
)
pure virtual

OBSOLETE.

◆ SetRulerOn()

virtual void IRhRdkCustomCurveCtrl::SetRulerOn ( bool  bOn)
pure virtual

Set the ruler on or off.

◆ SetScaleModeX()

virtual void IRhRdkCustomCurveCtrl::SetScaleModeX ( ScaleModes  m)
pure virtual

Set the X scale mode.

See also
MoveSelectedPoints().

◆ SetScaleModeY()

virtual void IRhRdkCustomCurveCtrl::SetScaleModeY ( ScaleModes  m)
pure virtual

Set the Y scale mode.

See also
MoveSelectedPoints().

◆ SetShadeConstraints()

virtual void IRhRdkCustomCurveCtrl::SetShadeConstraints ( bool  bOn)
pure virtual

Set whether or not the area outside the contraints is shaded.

◆ SetTangentColor()

virtual void IRhRdkCustomCurveCtrl::SetTangentColor ( const ON_Color col)
pure virtual

OBSOLETE.

◆ SetTangentScale()

virtual void IRhRdkCustomCurveCtrl::SetTangentScale ( double  d)
pure virtual

Set the scaling for displaying tangents on all curves.

◆ SetTangentSnapToAngle()

virtual void IRhRdkCustomCurveCtrl::SetTangentSnapToAngle ( double  dAngle)
pure virtual

Set the angle to snap tangent points to when the shift key is down.

◆ SetTextColor()

virtual void IRhRdkCustomCurveCtrl::SetTextColor ( const ON_Color col)
pure virtual

OBSOLETE.

◆ SetTextMode()

virtual void IRhRdkCustomCurveCtrl::SetTextMode ( TextModes  m)
pure virtual

Set the text mode.

◆ SetUseAutoScaling()

virtual void IRhRdkCustomCurveCtrl::SetUseAutoScaling ( bool  bOn)
pure virtual

Set whether or not auto-scaling is enabled.

◆ ShadeConstraints()

virtual bool IRhRdkCustomCurveCtrl::ShadeConstraints ( void  ) const
pure virtual
Returns
Whether or not the area outside the contraints is shaded.

◆ Style()

virtual Styles IRhRdkCustomCurveCtrl::Style ( void  ) const
pure virtual

Get the style that the control was created with.

◆ TangentColor()

virtual ON_Color IRhRdkCustomCurveCtrl::TangentColor ( void  ) const
pure virtual

Get the color of tangent lines and points for all curves.

◆ TangentScale()

virtual double IRhRdkCustomCurveCtrl::TangentScale ( void  ) const
pure virtual

Get the scaling for displaying tangents on all curves.

◆ TangentSnapToAngle()

virtual double IRhRdkCustomCurveCtrl::TangentSnapToAngle ( void  ) const
pure virtual
Returns
The angle to snap tangent points to when the shift key is down.

◆ TextColor()

virtual ON_Color IRhRdkCustomCurveCtrl::TextColor ( void  ) const
pure virtual

Get the color of the graph's text.

◆ TextMode()

virtual TextModes IRhRdkCustomCurveCtrl::TextMode ( void  ) const
pure virtual
Returns
The text mode.

◆ UnselectAllPoints()

virtual void IRhRdkCustomCurveCtrl::UnselectAllPoints ( bool  bIncludeTanPoints)
pure virtual

Unselect all the points on all enabled curves.

Parameters
bIncludeTanPointsindicates if tangent points should also be unselected.

◆ UseAutoScaling()

virtual bool IRhRdkCustomCurveCtrl::UseAutoScaling ( void  ) const
pure virtual
Returns
Whether or not auto-scaling is enabled.

◆ ZoomToExtents()

virtual void IRhRdkCustomCurveCtrl::ZoomToExtents ( void  )
pure virtual

Ask display to zoom such that all points on all curves fit within the window.

◆ ZoomToGraphRect()

virtual void IRhRdkCustomCurveCtrl::ZoomToGraphRect ( const ON_2dPoint pt1,
const ON_2dPoint pt2 
)
pure virtual

Ask display to zoom to a rectangle, in graph coords.

◆ ZoomToPixelRect()

virtual void IRhRdkCustomCurveCtrl::ZoomToPixelRect ( const ON_4iRect rect)
pure virtual

Ask display to zoom to a rectangle, in pixels.