Rhino C++ API  8.6
Public Member Functions | List of all members
IRhRdkDecal2 Class Referenceabstract

#include <IRhRdkDecal.h>

Inheritance diagram for IRhRdkDecal2:
IRhRdkDecal

Public Member Functions

virtual ON__UINT32 TextureRenderCRC (const CRhRdkContent::CRenderCRCFlags &rcrcFlags) const =0
 
virtual ON__UINT32 TextureRenderCRC (const CRhRdkContent::CRenderCRCFlags &rcrcFlags, const IRhRdkLinearWorkflow &lw) const =0
 
- Public Member Functions inherited from IRhRdkDecal
virtual ~IRhRdkDecal ()
 
virtual bool Color (const ON_3dPoint &ptPoint, const ON_3dVector &vecNormal, CRhRdkColor &colInOut, ON_2dPoint &uvOut) const =0
 
virtual RDK_DECAL_CRC CRC (void) const =0
 
virtual const IRhRdk_XMLSectionCustomData (void) const =0
 
virtual void * EVF (const wchar_t *, void *)=0
 
virtual void GetHorzSweep (double &sta, double &end) const =0
 
virtual void GetVertSweep (double &sta, double &end) const =0
 
virtual double Height (void) const =0
 
virtual RDK_DEPRECATED RDK_DECAL_CRC Id (void) const
 
virtual RDK_DEPRECATED double LatEnd (void) const
 
virtual RDK_DEPRECATED double LatStart (void) const
 
virtual RDK_DEPRECATED double LonEnd (void) const
 
virtual RDK_DEPRECATED double LonStart (void) const
 
virtual eMapping Mapping (void) const =0
 
virtual bool MapToInside (void) const =0
 
virtual ON_3dPoint Origin (void) const =0
 
virtual eProjection Projection (void) const =0
 
virtual double Radius (void) const =0
 
virtual void SetTexture (const CRhRdkTexture *pTexture)=0
 
virtual const CRhRdkTextureTexture (void) const =0
 
virtual UUID TextureInstanceId (void) const
 
virtual double Transparency (void) const =0
 
virtual void UVBounds (double &dMinUOut, double &dMinVOut, double &dMaxUOut, double &dMaxVOut) const =0
 
virtual ON_3dVector VectorAcross (void) const =0
 
virtual ON_3dVector VectorUp (void) const =0
 

Additional Inherited Members

- Public Types inherited from IRhRdkDecal
enum  eMapping {
  mapUnset =-1, mapPlanar = 0, mapCylindrical = 1, mapSpherical = 2,
  mapUV = 3, mapForce32bit = 0xFFFFFFFF
}
 
enum  eProjection {
  projUnset =-1, projForward = 0, projBackward = 1, projBoth = 2,
  projForce32bit = 0xFFFFFFFF
}
 
- Static Public Member Functions inherited from IRhRdkDecal
static bool GetTextureMapping (const IRhRdkDecal &decal, ON_TextureMapping &mappingOut)
 

Member Function Documentation

◆ TextureRenderCRC() [1/2]

virtual ON__UINT32 IRhRdkDecal2::TextureRenderCRC ( const CRhRdkContent::CRenderCRCFlags rcrcFlags) const
pure virtual

◆ TextureRenderCRC() [2/2]

virtual ON__UINT32 IRhRdkDecal2::TextureRenderCRC ( const CRhRdkContent::CRenderCRCFlags rcrcFlags,
const IRhRdkLinearWorkflow lw 
) const
pure virtual