Rhino C++ API  8.5
Public Member Functions | List of all members
IRhRdkDecalSupportEx Class Referenceabstract

#include <IRhRdkDecalSupportPlugIn.h>

Inheritance diagram for IRhRdkDecalSupportEx:
IRhRdkDecalSupport

Public Member Functions

virtual bool OnEditPropertiesEx (IRhRdk_XMLSection &section, CRhinoDoc *pDoc) const =0
 
- Public Member Functions inherited from IRhRdkDecalSupport
virtual ~IRhRdkDecalSupport ()
 
virtual void * EVF (const wchar_t *, void *)=0
 
virtual bool Initialize (IRhRdk_XMLSection &section) const =0
 
virtual bool OnEditProperties (IRhRdk_XMLSection &section) const =0
 
virtual bool SupportsEditProperties (void) const =0
 

Member Function Documentation

◆ OnEditPropertiesEx()

virtual bool IRhRdkDecalSupportEx::OnEditPropertiesEx ( IRhRdk_XMLSection section,
CRhinoDoc pDoc 
) const
pure virtual

Called when the user clicks the Properties button on the Decal Object Property page.

Parameters
sectionprovides your custom parameters and allows you to set them back after editing by the user.
pDocis the document containing the objects that have the decals.
Returns
true if editing completed successfully, else false.