Rhino C++ API  8.6
Public Member Functions | Protected Member Functions | List of all members
IRhRdkNotificationHandler Class Referenceabstract

#include <IRhRdkSectionHolder.h>

Public Member Functions

virtual void DeleteThis (void)=0
 
virtual void * EVF (const wchar_t *wszFunc, void *pvData)=0
 
virtual void OnBeginNotify (IRhinoUiWindow &w, unsigned int context)=0
 
virtual void OnEndNotify (IRhinoUiWindow &w, unsigned int context)=0
 
virtual void OnNotify (IRhinoUiWindow &w, const CRhRdkVariant &vOld, const CRhRdkVariant &vNew, unsigned int context)=0
 

Protected Member Functions

virtual ~IRhRdkNotificationHandler ()
 

Constructor & Destructor Documentation

◆ ~IRhRdkNotificationHandler()

virtual IRhRdkNotificationHandler::~IRhRdkNotificationHandler ( )
inlineprotectedvirtual

Member Function Documentation

◆ DeleteThis()

virtual void IRhRdkNotificationHandler::DeleteThis ( void  )
pure virtual

This method must be implemented as

delete this;

◆ EVF()

virtual void* IRhRdkNotificationHandler::EVF ( const wchar_t *  wszFunc,
void *  pvData 
)
pure virtual

Emergency virtual function for future expansion.

◆ OnBeginNotify()

virtual void IRhRdkNotificationHandler::OnBeginNotify ( IRhinoUiWindow w,
unsigned int  context 
)
pure virtual

This method is called when multiple notifications begin.

Parameters
wis the window sending the notification.
contextis a control-specific value.

◆ OnEndNotify()

virtual void IRhRdkNotificationHandler::OnEndNotify ( IRhinoUiWindow w,
unsigned int  context 
)
pure virtual

This method is called when multiple notifications end.

Parameters
wis the window sending the notification.
contextis a control-specific value.

◆ OnNotify()

virtual void IRhRdkNotificationHandler::OnNotify ( IRhinoUiWindow w,
const CRhRdkVariant vOld,
const CRhRdkVariant vNew,
unsigned int  context 
)
pure virtual

This method is called when a notification occurs.

Parameters
wis the window sending the notification.
vOldis the old value. The type depends on the sending control.
vNewis the new value. The type depends on the sending control.
contextis a control-specific value.