Rhino C++ API
8.13
|
#include <RhRdkTask.h>
Public Member Functions | |
virtual void | DeleteThis (void)=0 |
virtual void * | EVF (const wchar_t *, void *)=0 |
virtual bool | OnTaskRequestExecute (const UUID &uuidTask, const IRhRdkTaskOrigin &origin)=0 |
virtual void | OnTaskRequestUpdate (const UUID &uuidTask, IRhRdkTaskUpdate &tu)=0 |
Protected Member Functions | |
virtual | ~IRequestHandler () |
|
inlineprotectedvirtual |
|
pure virtual |
This method is implemented as
|
pure virtual |
Emergency virtual function for future expansion.
|
pure virtual |
The UI implements this method to execute a particular UI-bound task.
uuidTask | is the identifier of the task being executed. The UI only has to handle tasks that it cares about. |
|
pure virtual |
The UI implements this method to update a particular UI-bound task's enable or check state on a menu or other UI that displays tasks.
uuidTask | is the identifier of the task being updated. |
tu | is a task update object which you can use to get and set the check or enable state. |