Rhino C++ API
8.13
|
#include <RhRdkPlugIn.h>
Classes | |
class | CThumbnailMetrics |
Public Types | |
enum | orientation { or_vertical, or_horizontal } |
Public Member Functions | |
virtual void | Delete (void)=0 |
virtual UINT | DoubleClickedMessageNumber (void) const =0 |
virtual void * | EVF (const wchar_t *, void *)=0 |
virtual bool | GetContentArray (const CRhRdkThumbArray &aThumb, CRhRdkInstanceIdArray &aContentOut)=0 |
virtual bool | GetSelection (CRhRdkThumbArray &aThumbOut)=0 |
virtual bool | GetThumbnailMetrics (CThumbnailMetrics &m) const =0 |
virtual orientation | GridModeOrientation (void) const =0 |
virtual bool | IsScrollBarVisible (void) const =0 |
virtual void | MoveWindow (const ON_4iRect &rect)=0 |
virtual UINT | SelChangedMessageNumber (void) const =0 |
virtual UINT | SelChangingMessageNumber (void) const =0 |
virtual void | SetGridModeOrientation (orientation o)=0 |
virtual void | SetRdkDocument (const CRhRdkDocument &rdkDoc)=0 |
virtual bool | SetSelection (const CRhRdkThumbArray &aThumb)=0 |
virtual UINT | ThumbSizeChangedMessageNumber (void) const =0 |
virtual UUID | Uuid (void) const =0 |
Protected Member Functions | |
virtual | ~IRhRdkThumbnails () |
|
inlineprotectedvirtual |
|
pure virtual |
You must call this to delete the control after use.
|
pure virtual |
|
pure virtual |
Emergency virtual function for future expansion.
|
pure virtual |
Get the contents associated with a set of thumbnails. If the thumbnails are not displaying contents, the function will fail.
aThumb | is the array of thumbnail handles to return the contents for. |
aContentOut | accepts the associated content instance ids. |
|
pure virtual |
Get the set of selected thumbnails.
aThumbOut | accepts the thumbnail handles of the selected thumbnails. |
|
pure virtual |
Get the metrics of a thumbnail.
|
pure virtual |
Get the orientation the thumbnails have when in 'grid' mode. The default is or_vertical.
|
pure virtual |
|
pure virtual |
Set the position and size of the control.
rect | is the rectangle to move to, expressed in client coordinates of the parent. |
|
pure virtual |
|
pure virtual |
|
pure virtual |
Set the orientation the thumbnails should have when in 'grid' mode.
|
pure virtual |
Optionally set a document for the thumbnails to use. This is not required for modeless thumbnails because they find the document automatically. If you are writing a modal dialog, you may need to call this method and pass a special document to override the automatic default.
|
pure virtual |
Select a set of thumbnails.
aThumb | specifies the thumbnails to select. |
|
pure virtual |
|
pure virtual |