Rhino C++ API  8.6
Static Public Member Functions | List of all members
Internal_SubDToNurbsExtraordinaryPoint Class Reference

#include <opennurbs_plus_subd.h>

Static Public Member Functions

static const ON_INTERNAL_SDK bool Internal_TryRemoveDoubleKnotsDegFour (const int dir, ON_NurbsSurface *srf)
 

Member Function Documentation

◆ Internal_TryRemoveDoubleKnotsDegFour()

static const ON_INTERNAL_SDK bool Internal_SubDToNurbsExtraordinaryPoint::Internal_TryRemoveDoubleKnotsDegFour ( const int  dir,
ON_NurbsSurface srf 
)
static

Remove double knots if possible without changing the surface location, in a surface of degree 4 in direction dir. Internal use only in opennurbs_plus_brep_facegroups.cpp and opennurbs_plus_subd_mesh.cpp for dealing with SubD to NURBS conversions.