Rhino C++ API  8.6
Public Member Functions | Public Attributes | Static Public Attributes | List of all members
ON_2dex Class Reference

#include <opennurbs_defines.h>

Public Member Functions

 ON_2dex ()=default
 
 ON_2dex (const ON_2dex &)=default
 
 ON_2dex (int i, int j)
 
 ~ON_2dex ()=default
 
ON_2dex AsDecreasing () const
 return a copy of this item, where i is larger or equal to j More...
 
ON_2dex AsIncreasing () const
 return a copy of this item, where i is smaller or equal to j More...
 
bool operator!= (const ON_2dex &src) const
 
ON_2dexoperator= (const ON_2dex &)=default
 
bool operator== (const ON_2dex &src) const
 

Public Attributes

int i
 do not initialize i, j for performance reasons More...
 
int j
 

Static Public Attributes

static const ON_2dex Unset
 (ON_UNSET_INT_INDEX, ON_UNSET_INT_INDEX); More...
 
static const ON_2dex Zero
 (0, 0) More...
 

Detailed Description

pair of integer indices. This is intentionally a struct/typedef rather than a class so that it can be used in other structs.

Constructor & Destructor Documentation

◆ ON_2dex() [1/3]

ON_2dex::ON_2dex ( )
default

◆ ~ON_2dex()

ON_2dex::~ON_2dex ( )
default

◆ ON_2dex() [2/3]

ON_2dex::ON_2dex ( const ON_2dex )
default

◆ ON_2dex() [3/3]

ON_2dex::ON_2dex ( int  i,
int  j 
)

Member Function Documentation

◆ AsDecreasing()

ON_2dex ON_2dex::AsDecreasing ( ) const

return a copy of this item, where i is larger or equal to j

◆ AsIncreasing()

ON_2dex ON_2dex::AsIncreasing ( ) const

return a copy of this item, where i is smaller or equal to j

◆ operator!=()

bool ON_2dex::operator!= ( const ON_2dex src) const

◆ operator=()

ON_2dex& ON_2dex::operator= ( const ON_2dex )
default

◆ operator==()

bool ON_2dex::operator== ( const ON_2dex src) const

Member Data Documentation

◆ i

int ON_2dex::i

do not initialize i, j for performance reasons

◆ j

int ON_2dex::j

◆ Unset

const ON_2dex ON_2dex::Unset
static

(ON_UNSET_INT_INDEX, ON_UNSET_INT_INDEX);

◆ Zero

const ON_2dex ON_2dex::Zero
static

(0, 0)