Rhino C++ API
8.14
|
#include <opennurbs_ipoint.h>
Public Member Functions | |
ON_2iBoundingBox ()=default | |
ON_2iBoundingBox (const class ON_2iPoint bbox_min, const class ON_2iPoint bbox_max) | |
ON_2iBoundingBox (const ON_2iBoundingBox &)=default | |
~ON_2iBoundingBox ()=default | |
bool | IsSet () const |
const ON_2iPoint | Max () const |
const ON_2iPoint | Min () const |
ON_2iBoundingBox & | operator= (const ON_2iBoundingBox &)=default |
Public Attributes | |
ON_2iPoint | m_max |
ON_2iPoint | m_min |
Static Public Attributes | |
static const ON_2iBoundingBox | Unset |
(ON_2iPoint::Unset,ON_2iPoint::Unset) More... | |
static const ON_2iBoundingBox | Zero |
(ON_2iPoint::Origin,ON_2iPoint::Origin); More... | |
|
default |
Default construction intentionally leaves m_min and m_max uninitialized. Use something like ON_2iBoundingBox bbox(min_pt,max_pt); or ON_2iBoundingBox bbox = ON_2iBoundingBox::Unset;
|
default |
|
default |
ON_2iBoundingBox::ON_2iBoundingBox | ( | const class ON_2iPoint | bbox_min, |
const class ON_2iPoint | bbox_max | ||
) |
bool ON_2iBoundingBox::IsSet | ( | ) | const |
Returns: m_min.IsSet() && m_max.IsSet() && m_min.x <= m_max.x && m_min.y <= m_max.y.
const ON_2iPoint ON_2iBoundingBox::Max | ( | ) | const |
const ON_2iPoint ON_2iBoundingBox::Min | ( | ) | const |
|
default |
ON_2iPoint ON_2iBoundingBox::m_max |
ON_2iPoint ON_2iBoundingBox::m_min |
|
static |
|
static |