Rhino C++ API  8.6
Public Member Functions | Public Attributes | Static Public Attributes | List of all members
ON_3dex Class Reference

#include <opennurbs_defines.h>

Public Member Functions

 ON_3dex ()=default
 
 ON_3dex (const ON_3dex &)=default
 
 ON_3dex (int i, int j, int k)
 
 ~ON_3dex ()=default
 
ON_3dexoperator= (const ON_3dex &)=default
 

Public Attributes

int i
 do not initialize i, j, k for performance reasons More...
 
int j
 
int k
 

Static Public Attributes

static const ON_3dex Unset
 (ON_UNSET_UINT_INDEX, ON_UNSET_UINT_INDEX, ON_UNSET_UINT_INDEX); More...
 
static const ON_3dex Zero
 (0, 0, 0) More...
 

Constructor & Destructor Documentation

◆ ON_3dex() [1/3]

ON_3dex::ON_3dex ( )
default

◆ ~ON_3dex()

ON_3dex::~ON_3dex ( )
default

◆ ON_3dex() [2/3]

ON_3dex::ON_3dex ( const ON_3dex )
default

◆ ON_3dex() [3/3]

ON_3dex::ON_3dex ( int  i,
int  j,
int  k 
)

Member Function Documentation

◆ operator=()

ON_3dex& ON_3dex::operator= ( const ON_3dex )
default

Member Data Documentation

◆ i

int ON_3dex::i

do not initialize i, j, k for performance reasons

◆ j

int ON_3dex::j

◆ k

int ON_3dex::k

◆ Unset

const ON_3dex ON_3dex::Unset
static

(ON_UNSET_UINT_INDEX, ON_UNSET_UINT_INDEX, ON_UNSET_UINT_INDEX);

◆ Zero

const ON_3dex ON_3dex::Zero
static

(0, 0, 0)