#include <opennurbs_3dm_settings.h>
◆ ON_3dmViewPosition() [1/2]
ON_3dmViewPosition::ON_3dmViewPosition |
( |
| ) |
|
view window relative position and state in parent frame
◆ ~ON_3dmViewPosition()
ON_3dmViewPosition::~ON_3dmViewPosition |
( |
| ) |
|
◆ ON_3dmViewPosition() [2/2]
◆ Default()
void ON_3dmViewPosition::Default |
( |
| ) |
|
◆ operator=()
◆ Read()
◆ Write()
◆ m_bMaximized
bool ON_3dmViewPosition::m_bMaximized |
true if view window is maximized
◆ m_floating_viewport
unsigned char ON_3dmViewPosition::m_floating_viewport |
m_floating_viewport is used to track floating viewport information. 0 = the view is docked in the main application window. >0 = the view is floating. When floating, this corresponds to the number of monitors on on the user's computer when the file was saved
◆ m_wnd_bottom
double ON_3dmViewPosition::m_wnd_bottom |
◆ m_wnd_left
double ON_3dmViewPosition::m_wnd_left |
0.0 to 1.0
relative position of view window in main frame if m_floating_viewport>0, this is relative position of the view window on the virtual screen (union of potentially multiple monitors)
◆ m_wnd_right
double ON_3dmViewPosition::m_wnd_right |
◆ m_wnd_top
double ON_3dmViewPosition::m_wnd_top |