#include <opennurbs_internal_glyph.h>
◆ CompareFontPointer()
static int ON_ManagedFonts::CompareFontPointer |
( |
ON_Font const *const * |
lhs, |
|
|
ON_Font const *const * |
rhs |
|
) |
| |
|
static |
sorts nulls to end of lists
◆ GetFontMetricsInFontDesignUnits()
static bool ON_ManagedFonts::GetFontMetricsInFontDesignUnits |
( |
const ON_Font * |
font, |
|
|
ON_FontMetrics & |
font_metrics_in_font_design_units |
|
) |
| |
|
static |
Parameters: font - [in] font_metrics_in_font_design_units - [out] Returns: True: font_metrics_in_font_design_units set from a font installed on the current device. False: ON_FontMetrics::LastResortMetrics used or other corrections applied.
◆ GetFromFontCharacteristics()
const ON_Font* ON_ManagedFonts::GetFromFontCharacteristics |
( |
const ON_Font & |
font_characteristics, |
|
|
bool |
bCreateIfNotFound |
|
) |
| |
◆ GetFromSerialNumber()
const ON_Font* ON_ManagedFonts::GetFromSerialNumber |
( |
unsigned int |
managed_font_runtime_serial_number | ) |
|
◆ GetGlyphMetricsInFontDesignUnits()
static unsigned int ON_ManagedFonts::GetGlyphMetricsInFontDesignUnits |
( |
const class ON_Font * |
font, |
|
|
ON__UINT32 |
unicode_code_point, |
|
|
class ON_TextBox & |
glyph_metrics_in_font_design_units |
|
) |
| |
|
static |
Returns: 0: failure >0: success font glyph index
◆ InstalledFonts()
static const ON_FontList& ON_ManagedFonts::InstalledFonts |
( |
| ) |
|
|
static |
◆ ManagedFonts()
static const ON_FontList& ON_ManagedFonts::ManagedFonts |
( |
| ) |
|
|
inlinestatic |
◆ List
List is the only instance of this class.