Rhino C++ API  8.6
Public Member Functions | Public Attributes | List of all members
RhShutLiningArgs Class Reference

Shut-lining arguments. More...

#include <rhinoSdkMeshUtilities.h>

Public Member Functions

 RhShutLiningArgs ()
 The constructor sets the default arguments. More...
 

Public Attributes

bool m_bFaceted
 Specifies whether the shutline is faceted. More...
 
ON_ClassArray< RhShutLiningCurveArgsm_curveArgs
 A collection of curve arguments. More...
 
double m_dTolerance
 The tolerance of the shutline. More...
 

Detailed Description

Shut-lining arguments.

Constructor & Destructor Documentation

◆ RhShutLiningArgs()

RhShutLiningArgs::RhShutLiningArgs ( )

The constructor sets the default arguments.

Member Data Documentation

◆ m_bFaceted

bool RhShutLiningArgs::m_bFaceted

Specifies whether the shutline is faceted.

◆ m_curveArgs

ON_ClassArray<RhShutLiningCurveArgs> RhShutLiningArgs::m_curveArgs

A collection of curve arguments.

◆ m_dTolerance

double RhShutLiningArgs::m_dTolerance

The tolerance of the shutline.