Rhino C++ API  8.6
Public Attributes | List of all members
ON_3DM_CHUNK Struct Reference

#include <opennurbs_archive.h>

Public Attributes

ON__UINT16 m_crc16
 
ON__UINT32 m_crc32
 
ON__UINT16 m_do_crc16
 16 bit CRC using CCITT polynomial More...
 
ON__UINT32 m_do_crc32
 32 bit CRC More...
 
int m_do_length
 true if chunk is a long chunk with length More...
 
size_t m_offset
 
unsigned int m_typecode
 
int m_value
 

Detailed Description

ON_BinaryArchive virtual class for CPU independent serialization

ON_BinaryFile simple class for CPU independent binary file I/O includes optional CRC support

Member Data Documentation

◆ m_crc16

ON__UINT16 ON_3DM_CHUNK::m_crc16

◆ m_crc32

ON__UINT32 ON_3DM_CHUNK::m_crc32

◆ m_do_crc16

ON__UINT16 ON_3DM_CHUNK::m_do_crc16

16 bit CRC using CCITT polynomial

◆ m_do_crc32

ON__UINT32 ON_3DM_CHUNK::m_do_crc32

32 bit CRC

◆ m_do_length

int ON_3DM_CHUNK::m_do_length

true if chunk is a long chunk with length

◆ m_offset

size_t ON_3DM_CHUNK::m_offset

In read or write_using_fseek mode, this is the file position of first byte after chunk's length. In write_using_buffer mode, this of the m_buffer[] position of first byte after chunk's length.

◆ m_typecode

unsigned int ON_3DM_CHUNK::m_typecode

◆ m_value

int ON_3DM_CHUNK::m_value