Rhino C++ API  8.6
Public Attributes | List of all members
ON_MeshTopologyEdge Struct Reference

#include <opennurbs_mesh.h>

Public Attributes

int m_topf_count
 m_topf_count = number of topological faces that share this topological edge. More...
 
const int * m_topfi
 
int m_topvi [2]
 m_topvi[] = indices of the topological vertices where the edge begins and ends. More...
 

Member Data Documentation

◆ m_topf_count

int ON_MeshTopologyEdge::m_topf_count

m_topf_count = number of topological faces that share this topological edge.

◆ m_topfi

const int* ON_MeshTopologyEdge::m_topfi

m_topfi[] is an array of length m_topf_count with the indices of the topological faces that share this topological edge.

◆ m_topvi

int ON_MeshTopologyEdge::m_topvi[2]

m_topvi[] = indices of the topological vertices where the edge begins and ends.