Rhino C++ API  8.6
Public Attributes | List of all members
ON_MeshTopologyVertex Struct Reference

#include <opennurbs_mesh.h>

Public Attributes

int m_tope_count
 
const int * m_topei
 
int m_v_count
 
const int * m_vi
 

Detailed Description

Class ON_MeshTopology

Member Data Documentation

◆ m_tope_count

int ON_MeshTopologyVertex::m_tope_count

m_tope_count = number of topological edges that begin or end at this topological vertex.

◆ m_topei

const int* ON_MeshTopologyVertex::m_topei

m_topei[] is an array of length m_tope_count with the indices of the topological edges that begin or end at this topological vertex. Generally, these edges are listed in no particular order. If you want the edges listed "radially", then call ON_MeshTopology::SortVertexEdges.

◆ m_v_count

int ON_MeshTopologyVertex::m_v_count

m_v_count = number of ON_Mesh vertices that correspond to this topological vertex.

◆ m_vi

const int* ON_MeshTopologyVertex::m_vi

m_vi[] is an array of length m_v_count with the indices of the ON_Mesh vertices that correspond to this topological vertex.