Rhino C++ API  8.6
Public Attributes | List of all members
ON_UUID_struct Struct Reference

ON_UUID is a 16 byte universally unique identifier. More...

#include <opennurbs_uuid.h>

Public Attributes

unsigned int Data1
 32 bit unsigned integer More...
 
unsigned short Data2
 16 bit unsigned integer More...
 
unsigned short Data3
 16 bit unsigned integer More...
 
unsigned char Data4 [8]
 

Detailed Description

ON_UUID is a 16 byte universally unique identifier.

Member Data Documentation

◆ Data1

unsigned int ON_UUID_struct::Data1

32 bit unsigned integer

◆ Data2

unsigned short ON_UUID_struct::Data2

16 bit unsigned integer

◆ Data3

unsigned short ON_UUID_struct::Data3

16 bit unsigned integer

◆ Data4

unsigned char ON_UUID_struct::Data4[8]