Rhino C++ API  8.6
Public Attributes | List of all members
ON_WindowsRGBQUAD Struct Reference

Windows sizeof(ON_WindowsRGBQUAD) = 4. More...

#include <opennurbs_bitmap.h>

Public Attributes

unsigned char rgbBlue
 BYTE. More...
 
unsigned char rgbGreen
 BYTE. More...
 
unsigned char rgbRed
 BYTE. More...
 
unsigned char rgbReserved
 BYTE. More...
 

Detailed Description

Windows sizeof(ON_WindowsRGBQUAD) = 4.

These are the values of the Windows defines mentioned in the comment below. If you're running on Windows, they get defined by Windows system header files. If you aren't running on Windows, then you don't need them. define BI_RGB 0L define BI_RLE8 1L define BI_RLE4 2L define BI_BITFIELDS 3L

Member Data Documentation

◆ rgbBlue

unsigned char ON_WindowsRGBQUAD::rgbBlue

BYTE.

Mimics Windows RGBQUAD structure. For details searh for "RGBQUAD" at http://msdn.microsoft.com/default.asp

◆ rgbGreen

unsigned char ON_WindowsRGBQUAD::rgbGreen

BYTE.

◆ rgbRed

unsigned char ON_WindowsRGBQUAD::rgbRed

BYTE.

◆ rgbReserved

unsigned char ON_WindowsRGBQUAD::rgbReserved

BYTE.