Grasshopper API
Grasshopper API
Grasshopper
DataTree(T) Class
DataTree(T) Methods
Add Method
AddRange Method
AllData Method
Branch Method
Clear Method
ClearData Method
EnsurePath Method
Flatten Method
Graft Method
Insert Method
ItemExists Method
MergeTree Method
Path Method
PathExists Method
RemovePath Method
RenumberPaths Method
SimplifyPaths Method
ToString Method
TrimExcess Method
DataTree
T
ClearData Method
Removes all data from all branches without affecting the tree topology.
Namespace:
Grasshopper
Assembly:
Grasshopper (in Grasshopper.dll)
Syntax
C#
VB
Copy
public
void
ClearData
()
Public
Sub
ClearData
See Also
Reference
DataTree
T
Class
Grasshopper Namespace
Grasshopper for Rhino 8.13.24317.13000 (2024-11-12)
Copyright © 2009-2024 Robert McNeel & Associates
Report wishes and bugs at discourse.mcneel.com