Click or drag to resize

DataTreeTMergeTree Method

Merges two trees together. Data inside similar branches will be merged into single lists and unique paths will be appended. The other tree will not be altered, so beware that data is now shared among both trees.

Namespace:  Grasshopper
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public void MergeTree(
	DataTree<T> other
)

Parameters

other
Type: GrasshopperDataTreeT
Tree to merge with.
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown if other is a null reference.
See Also