Click or drag to resize

GH_BorderCreateBorders Method (RectangleF, Int32, Int32, Int32, Int32)

Static (Shared) method for creating a set of borders.

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static List<GH_Border> CreateBorders(
	RectangleF box,
	int borderLeft,
	int borderRight,
	int borderTop,
	int borderBottom
)

Parameters

box
Type: System.DrawingRectangleF
Box for border creation.
borderLeft
Type: SystemInt32
Width of the leftmost border.
borderRight
Type: SystemInt32
Width of the rightmost border.
borderTop
Type: SystemInt32
Width of the topmost border.
borderBottom
Type: SystemInt32
Width of the bottommost border.

Return Value

Type: ListGH_Border
A list of borders.
See Also