Click or drag to resize

GH_Border Class

Represents a resizing border of a Grasshopper canvas object.
Inheritance Hierarchy

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Border

The GH_Border type exposes the following members.

Constructors
  NameDescription
Public methodGH_Border
Create a new border.
Top
Properties
  NameDescription
Public propertyRegion
Gets the shape of the border.
Public propertySize_Cursor
Gets the cursor associated with this border.
Public propertyTopology
Gets the type of border.
Top
Methods
  NameDescription
Public methodContains
Test a point for border inclusion.
Public methodStatic memberCreateBorders(RectangleF, Int32)
Static (Shared) method for creating a set of borders.
Public methodStatic memberCreateBorders(RectangleF, Padding)
Static (Shared) method for creating a set of borders.
Public methodStatic memberCreateBorders(RectangleF, Int32, Int32)
Static (Shared) method for creating a set of borders.
Public methodStatic memberCreateBorders(RectangleF, Int32, Int32, Int32, Int32)
Static (Shared) method for creating a set of borders.
Top
See Also