Click or drag to resize

GH_ActiveObject.AddRuntimeMessage Method

Add a new message to this object. Valid message type flags are Warning and Error. If the Message string is empty or zero-length no message is added.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public virtual void AddRuntimeMessage(
	GH_RuntimeMessageLevel level,
	string text
)

Parameters

level
Type: Grasshopper.Kernel.GH_RuntimeMessageLevel
Type of message. Only Warnings and Errors are recorded.
text
Type: System.String
Content of message.

Implements

IGH_ActiveObject.AddRuntimeMessage(GH_RuntimeMessageLevel, String)
See Also