Click or drag to resize

GH_ActiveObject Class

Basic implementation of IGH_ActiveObject interface. Derive from this class rather than implementing IGH_ActiveObject to make your life easier.
Inheritance Hierarchy

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract class GH_ActiveObject : GH_DocumentObject, 
	IGH_ActiveObject

The GH_ActiveObject type exposes the following members.

Constructors
  NameDescription
Protected methodGH_ActiveObject(IGH_InstanceDescription)
Initializes a new instance of the GH_ActiveObject class
Protected methodGH_ActiveObject(String, String, String, String, String)
Initializes a new instance of the GH_ActiveObject class
Top
Properties
  NameDescription
Public propertyIconCapableUI
By default the NickName menu item supports the Icon Mode override toggle. If your UI is not capable of displaying icons, then override this property and return False.
Public propertyIsDataProvider
Returns a boolean indicating whether or not the current object can seed data.
Public propertyLocked
Gets or sets the enabled flag of this object. Disabled objects are ignored during solutions.
Public propertyMutableNickName
Gets or sets a value that enables Nick name changes through the menu. The default is TRUE.
Public propertyPhase
Gets or sets the solution phase this object is currenly in.
Public propertyProcessorTime
Gets the most recent processor time profiler value.
Public propertyRuntimeMessageLevel
Returns the worst case flag for the current object

If the object contains at least 1 error, the result is Error.

If the object contains at least 1 warning, the result is Warning.

If the object contains at least 1 message, the result is Remark.

If the object contains no errors, no warnings and no messages, the result is Blank.

Top
Methods
  NameDescription
Public methodAddRuntimeMessage
Add a new message to this object. Valid message type flags are Warning and Error. If the Message string is empty or zero-length no message is added.
Public methodAppendAdditionalMenuItems
Override this function if you want to add additional items to the object context menu. Default items already included in the menu toolstrip are:

1. Name

2. Preview

3. Warnings

4. Errors

5. [additional items will be inserted here]

6. Help

Public methodAppendMenuItems
This function is called when a context menu is about to be displayed. Override it to set custom items. GH_ActiveObject will already populate the menu with default items, if you merely wish to insert object-specific menu item, consider overriding AppendAdditionalMenuItems instead.
(Overrides GH_DocumentObjectAppendMenuItems(ToolStripDropDown).)
Public methodClearData
This function is called whenever the object needs to clear all solution data. Override this function if you need to perform custom clensing.
Public methodClearRuntimeMessages
Destroy all warning and error lists
Public methodCollectData
This function is called whenever the object is required to collect all data. Either from Persistent records, from source params or whatever.
Public methodComputeData
This function is called whenever the object is required to generate new data.
Public methodDependsOn
Returns a boolean indicating whether or not the current object somehow inherits from the PotenialSource object
Protected methodExpireDownStreamObjects
This function is called whenever the solution for this object expires. Override this function if objects depend on you.
Public methodExpireSolution
Informs the document that owns this object that the solution has expired. The current object will be set to BLANK as a result. This method is recursive, it will also expire any and all objects which depend on this object. If you want a less destructive expiration, consider using ClearData(). If this object is already Blank, you should consider not expiring it.
(Overrides GH_DocumentObjectExpireSolution(Boolean).)
Protected methodMenu_AppendBakeItem
Append the default Bake menu item.
Protected methodMenu_AppendEnableItem
Append the default Enable/Disable menu item.
Protected methodMenu_AppendPreviewItem
Append the default Show/Hide preview menu item.
Protected methodMenu_AppendRuntimeMessages
Append the default warnings and errors menu items.
Public methodRead (Overrides GH_DocumentObjectRead(GH_IReader).)
Public methodRegisterRemoteIDs
Override this function if you want object changes in the Rhino document to trigger a new solution.
Public methodRuntimeMessages
Gets the list of cached runtime messages that were recorded during solver-time processes.
Public methodSDKCompliancy
Test whether this object is compliant with a given Rhino version.
Public methodWrite (Overrides GH_DocumentObjectWrite(GH_IWriter).)
Top
Events
  NameDescription
Top
Fields
  NameDescription
Top
See Also