Click or drag to resize

GH_FileWatcherCreateDirectoryWatcher Method (String, String, GH_FileWatcherEvents, GH_FileWatcherFileChangedSimple)

Create a new FileSystem Watcher object aimed at a specific file.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static GH_FileWatcher CreateDirectoryWatcher(
	string folderPath,
	string filter,
	GH_FileWatcherEvents events,
	GH_FileWatcherFileChangedSimple delegate
)

Parameters

folderPath
Type: SystemString
Folder to watch.
filter
Type: SystemString
Filter string for filenames.
events
Type: Grasshopper.KernelGH_FileWatcherEvents
Events to watch for.
delegate
Type: Grasshopper.KernelGH_FileWatcherFileChangedSimple
Callback delegate.

Return Value

Type: GH_FileWatcher
A new filewatcher aimed at the specified folder.
See Also