Click or drag to resize

GH_FileWatcherCreateFileWatcher Method (String, GH_FileWatcherEvents, GH_FileWatcherFileChanged)

Create a new FileSystem Watcher object aimed at a specific file.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static GH_FileWatcher CreateFileWatcher(
	string filePath,
	GH_FileWatcherEvents events,
	GH_FileWatcherFileChanged delegate
)

Parameters

filePath
Type: SystemString
File to watch.
events
Type: Grasshopper.KernelGH_FileWatcherEvents
Events to watch for.
delegate
Type: Grasshopper.KernelGH_FileWatcherFileChanged
Callback delegate.

Return Value

Type: GH_FileWatcher
A new filewatcher aimed at the specified file.
See Also