Click or drag to resize

GH_FileWatcherFileChanged Delegate

Delegate method for file change callbacks.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public delegate void FileChanged(
	GH_FileWatcher sender,
	string filename,
	WatcherChangeTypes change
)

Parameters

sender
Type: Grasshopper.KernelGH_FileWatcher
FileWatcher that invoked the delegate.
filename
Type: SystemString
Path to file that is being watched.
change
Type: System.IOWatcherChangeTypes
The type of change that occured.
See Also