Click or drag to resize

GH_ParamTAddVolatileData Method (GH_Path, Int32, Object)

Inserts an item of volatile data into the data structure.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public bool AddVolatileData(
	GH_Path path,
	int index,
	Object data
)

Parameters

path
Type: Grasshopper.Kernel.DataGH_Path
The branch path of the data. If the path doesn't exist yet, it will be created.
index
Type: SystemInt32
The item index of the data. If the path doesn't contain the index yet, it will be enlarged to encompass the index.
data
Type: SystemObject
The data to store.

Return Value

Type: Boolean
True on success, False on failure. If the data cannot be converted, the topology will remain unmolested.

Implements

IGH_ParamAddVolatileData(GH_Path, Int32, Object)
See Also