Click or drag to resize

GH_ParamT Class

Base implementation of IGH_Param. Derive from this class rather than implementing IGH_Param from scratch. If your parameter can store persistent data, derive from GH_PersistentParam(Of T) instead.
Inheritance Hierarchy

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract class GH_Param<T> : GH_ActiveObject, 
	IGH_Param
where T : class, IGH_Goo

Type Parameters

T
Data type for this parameter.

The GH_ParamT type exposes the following members.

Constructors
  NameDescription
Protected methodGH_ParamT(IGH_InstanceDescription)
Initializes a new instance of the GH_ParamT class
Protected methodGH_ParamT(IGH_InstanceDescription, GH_ParamAccess)
Initializes a new instance of the GH_ParamT class
Protected methodGH_ParamT(String, String, String, String, String, GH_ParamAccess)
Initializes a new instance of the GH_ParamT class
Top
Properties
  NameDescription
Public propertyAccess
Gets or sets the Access level for this parameter.
Public propertyDataMapping
Gets or sets the data mapping of this Parameter.
Public propertyDataType
Type is either Void if there are no sources or Remote. Derived classes should expand on this.
Public propertyHasProxySources
Gets a value indicating whether or not this parameter maintains proxy sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.
Public propertyInstanceDescription
Gets the description of this instance. The default description is about the amount and source of the local values.
(Overrides GH_InstanceDescriptionInstanceDescription.)
Public propertyIsDataProvider (Overrides GH_ActiveObjectIsDataProvider.)
Public propertyIsPrincipal
Gets whether this parameter is a principal parameter. Principal parameters are maintained by components and are not part of the IGH_Param interface.
Public propertyKind
Gets the parameter kind. The kind is evaluated lazily and cached.
Public propertyOptional
Gets or sets whether or not this parameter is considered optional by the owner component. Empty, non-optional parameters prevent the component from being solved.
Public propertyProcessorTime (Overrides GH_ActiveObjectProcessorTime.)
Public propertyProxySourceCount
Gets the number of proxy sources for this parameter. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.
Public propertyRecipients
Gets a list of all the recipients of this parameter. I.e. a recipient has this parameter as one of the sources. The Recipient list is maintained by the parameter, do not modify it yourself.
Public propertyReverse
Gets or sets the data reverse modifier of this parameter.
Public propertyRuntimeMessageLevel
Returns the worst case flag for the current object

If the object contains at least 1 error, the result is Error.

If the object contains at least 1 warning, the result is Warning.

If the object contains at least 1 message, the result is Remark.

If the object contains no errors, no warnings and no messages, the result is Blank.
Public propertySimplify
Gets or sets the simplify modifier for this parameter.
Public propertySourceCount
Gets the number of sources for this parameter.
Public propertySources
Gets a list of source parameters. Do not modify this list, if you wish to add or remove sources, use dedicated functions like AddSource() and RemoveSource() instead.
Public propertyStateTags
Gets all the StateTags that are associated with this parameter. A state tag is a visual feedback icon that represents specific internal settings.
Public propertyType
Gets the Framework Type descriptor for the stored Data.
Public propertyTypeName
Calls TypeName() on the first instance of T it can find. This is either an item in the volatile list, or a newly constructed instance.
Public propertyVolatileData
Public propertyVolatileDataCount
Public propertyWireDisplay
Gets or sets the wire display style for this parameter. Wire display only affects the wires connected to the parameter input.
Top
Methods
  NameDescription
Public methodAddSource(IGH_Param)
Append a new Source parameter to the end of the Sources list. Sources provide this parameter with data at runtime.
Public methodAddSource(IGH_Param, Int32)
Insert a new Source parameter into the Sources list. Sources provide this parameter with data at runtime.
Public methodAddVolatileData(GH_Path, Int32, T)
Public methodAddVolatileData(GH_Path, Int32, Object)
Inserts an item of volatile data into the data structure.
Public methodAddVolatileDataList(GH_Path, ListT)
Public methodAddVolatileDataList(GH_Path, IEnumerable)
Public methodAddVolatileDataTree(GH_StructureT)
Public methodAddVolatileDataTree(IGH_Structure)
Public methodAppendAdditionalMenuItems
Override this function if you want to add specific items to the object context menu Default items already included in the menu toolstrip are: 1. Name 2. Preview 3. Warnings 4. Errors
(Overrides GH_ActiveObjectAppendAdditionalMenuItems(ToolStripDropDown).)
Protected methodCast_Object
Attempts to convert the Object reference into an instance of T. This method will perform a direct cast if possible or it will call Casting functions on T or Data if they exist. Data will not be duplicated unless a type conversion is required.
Public methodClearData (Overrides GH_ActiveObjectClearData.)
Public methodClearProxySources
Remove all proxy sources without attempting to relink them.
Public methodCollectData (Overrides GH_ActiveObjectCollectData.)
Protected methodCollectVolatileData_Custom
If a parameter has no sources, the CollectVolatileData_Custom() method is called. The basic implementation does nothing, but you can override this method to provide special data instantiation logic.
Protected methodCollectVolatileData_FromSources
This method collects volatile data from all the source parameters.
Public methodComputeData (Overrides GH_ActiveObjectComputeData.)
Protected methodConversionCallback
This method is called whenever a successful conversion takes place from some source data into local target data. Override it if you wish to keep tabs on conversions.
Public methodCreateAttributes (Overrides GH_DocumentObjectCreateAttributes.)
Public methodCreateProxySources
Convert all proper source parameters into proxy sources.
Public methodDependsOn (Overrides GH_ActiveObjectDependsOn(IGH_ActiveObject).)
Protected methodExpireDownStreamObjects (Overrides GH_ActiveObjectExpireDownStreamObjects.)
Public methodExpireSolutionTopLevel
Invoke the Expiresolution(bool) method on the toplevel object.
Protected methodFormat
Returns "Null" if the data is a null reference, otherwise calls ToString() on the Data instance.
Protected methodInstantiateT
Attempts to instantiate a new instance of T.
Public methodIsolateObject (Overrides GH_DocumentObjectIsolateObject.)
Protected methodMenu_AppendDisconnectWires
Protected methodMenu_AppendFlattenParameter
Protected methodMenu_AppendGraftParameter
Protected methodMenu_AppendPrincipalParameter
Protected methodMenu_AppendReverseParameter
Protected methodMenu_AppendSimplifyParameter
Protected methodMenu_AppendWireDisplay
Protected methodOnVolatileDataCollected
Once volatile data has been collected this method will be calles. The basic implementation does nothing, but you can add code here to post-process or analyze the volatile data.
Protected methodPreferredCast
Implement this function if you're certain that you'll be confronted with very common casts. For example, GH_Point has a preferred cast from Rhino.Geometry.Point3d and GH_Number has a preferred cast from System.Double.
Protected methodPreview_ComputeClippingBox
This function can be used to iterate over all items in the Volatile data tree and collect the union clipping box of all non-null items that implement Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself.
Protected methodPreview_DrawMeshes
This function can be used to iterate over all items in the Volatile data tree and call DrawViewportWires on each item that implements Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself.
Protected methodPreview_DrawWires
This function can be used to iterate over all items in the Volatile data tree and call DrawViewportWires on each item that implements Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself.
Public methodRead (Overrides GH_ActiveObjectRead(GH_IReader).)
Protected methodRegisterRemoteIDsUtil
Utility function which treats all data in the Volatile cache as IGH_GeometricGoo and registers all referenced objects. Call this function from within RegisterRemoteIDs() if you are absolutely sure that all the items in volatiledata implement IGH_GeometricGoo.
Public methodRelinkProxySources
Attempt to replace all proxy sources with real sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.
Public methodRemoveAllSources
Remove all sources from this parameter.
Public methodRemoveEffects
Remove all post-process effects. Note to implementors, you must call the base method if you override this function.
Public methodRemoveSource(Guid)
Remove the specified source from this parameter.
Public methodRemoveSource(IGH_Param)
Remove the specified source from this parameter.
Protected methodRender_AppendGeometry Obsolete.
This function has been emptied because it is Obsolete.
Public methodReplaceSource(Guid, IGH_Param)
Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens.
Public methodReplaceSource(IGH_Param, IGH_Param)
Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens.
Public methodSetPrincipal
Set the principal parameter state.
Protected methodVolatileDataDescription
This method is called to populate the Tooltip data description field.
Public methodWrite (Overrides GH_ActiveObjectWrite(GH_IWriter).)
Top
Events
  NameDescription
Top
Fields
  NameDescription
Protected fieldm_data
Contains the runtime data for this parameter, also known as "Volatile" data.
Top
See Also