Click or drag to resize

GH_PersistentParam<T>.SetPersistentData Method (GH_Structure<T>)

Assign a tree of items to the persistent data. This method will erase any existing data, record an undo event, raise the OnObjectChanged event for PersistentData flags and place a call to ExpireSolution(False). If you want to add a tree of data, you should use the appropriate overload for this method.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public void SetPersistentData(
	GH_Structure<T> items
)

Parameters

items
Type: Grasshopper.Kernel.Data.GH_Structure<T>
Items to add.
See Also