Click or drag to resize

GH_PersistentParamTSetPersistentData Method (T)

Add a single item to the persistent data. This method will record an undo event, raise the OnObjectChanged event for PersistentData flags and place a call to ExpireSolution(False). If you want to add more than one piece of data, you should use the appropriate overload for this method.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public void SetPersistentData(
	T item
)

Parameters

item
Type: T
Item to add.
See Also