Click or drag to resize

GH_PersistentParamT Class

Implementation of GH_Param(Of T) that supports persistent data.
Inheritance Hierarchy

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract class GH_PersistentParam<T> : GH_Param<T>
where T : class, IGH_Goo

Type Parameters

T
Data type for this parameter.

The GH_PersistentParamT type exposes the following members.

Constructors
  NameDescription
Protected methodGH_PersistentParamT(GH_InstanceDescription)
Initializes a new instance of the GH_PersistentParamT class
Protected methodGH_PersistentParamT(GH_InstanceDescription, Boolean) Obsolete.
Initializes a new instance of the GH_PersistentParamT class
Protected methodGH_PersistentParamT(String, String, String, String, String)
Initializes a new instance of the GH_PersistentParamT class
Top
Properties
  NameDescription
Public propertyDataType
Gets the type of data stored in this parameter.
(Overrides GH_ParamTDataType.)
Public propertyPersistentData
Gets the persistent data stored in this parameter. If you modify the persistent data, be sure to call the: OnObjectChanged(GH_ObjectEventType.PersistentData) event.
Public propertyPersistentDataCount
Gets the number of persistent data items stored in this parameter.
Public propertyRuntimeMessageLevel
Returns the worst case flag for the current object

If the object contains at least 1 error, the result is Error.

If the object contains at least 1 warning, the result is Warning.

If the object contains at least 1 message, the result is Remark.

If the object contains no errors, no warnings and no messages, the result is Blank.
Top
Methods
  NameDescription
Public methodAppendAdditionalMenuItems (Overrides GH_ParamTAppendAdditionalMenuItems(ToolStripDropDown).)
Protected methodCollectVolatileData_Custom (Overrides GH_ParamTCollectVolatileData_Custom.)
Protected methodMenu_AppendDestroyPersistent
Protected methodMenu_AppendExtractParameter
Protected methodMenu_AppendInternaliseData
Protected methodMenu_AppendManageCollection
Protected methodMenu_AppendPromptMore
Protected methodMenu_AppendPromptOne
Protected methodMenu_CreateMultilineTextEditItem
This function returns a ToolstripMenuItem that embeds a multi-line textbox for editing persistent data. Only call this method if you know that your parameter type supports proxies.
Protected methodMenu_CustomMultiValueItem
Protected methodMenu_CustomSingleValueItem
Protected methodPrepareForPrompt
Protected methodPrompt_ManageCollection
Protected methodPrompt_Plural
Protected methodPrompt_Singular
Public methodRead (Overrides GH_ParamTRead(GH_IReader).)
Protected methodRecordPersistentDataEvent
Add an undo record that stores changes to persistent data.
Protected methodRecoverFromPrompt
Public methodSetPersistentData(T)
Add a single item to the persistent data. This method will record an undo event, raise the OnObjectChanged event for PersistentData flags and place a call to ExpireSolution(False). If you want to add more than one piece of data, you should use the appropriate overload for this method.
Public methodSetPersistentData(GH_StructureT)
Assign a tree of items to the persistent data. This method will erase any existing data, record an undo event, raise the OnObjectChanged event for PersistentData flags and place a call to ExpireSolution(False). If you want to add a tree of data, you should use the appropriate overload for this method.
Public methodSetPersistentData(IEnumerableT)
Assign a list of items to the persistent data. This method will erase any existing data, record an undo event, raise the OnObjectChanged event for PersistentData flags and place a call to ExpireSolution(False). If you want to add a tree of data, you should use the appropriate overload for this method.
Public methodSetPersistentData(Object)
Add a collection of values to the persistent data.
Public methodWrite (Overrides GH_ParamTWrite(GH_IWriter).)
Top
Events
  NameDescription
Top
Fields
See Also