Node3dTNearestItem Method (Double, Double, Double) |
Find the nearest item.
Namespace:
Grasshopper.Kernel.Geometry.SpatialTrees
Assembly:
Grasshopper (in Grasshopper.dll)
Syntax public Index3d<T> NearestItem(
double x,
double y,
double z
)
Public Function NearestItem (
x As Double,
y As Double,
z As Double
) As Index3d(Of T)
Parameters
- x
- Type: SystemDouble
x coordinate to search from. - y
- Type: SystemDouble
y coordinate to search from. - z
- Type: SystemDouble
z coordinate to search from.
Return Value
Type:
Index3dTThe index of the nearest item or null if no nearest item could be found.
See Also