Click or drag to resize

Node3dTNearestItem Method (Double, Double, Double, Validation3dT)

Find the nearest item using custom validation criteria.

Namespace:  Grasshopper.Kernel.Geometry.SpatialTrees
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public Index3d<T> NearestItem(
	double x,
	double y,
	double z,
	Validation3d<T> validationDelegate
)

Parameters

x
Type: SystemDouble
x coordinate to search from.
y
Type: SystemDouble
y coordinate to search from.
z
Type: SystemDouble
z coordinate to search from.
validationDelegate
Type: Grasshopper.Kernel.Geometry.SpatialTreesValidation3dT
Item validation delegate.

Return Value

Type: Index3dT
The index of the nearest item or null if no nearest item could be found.
See Also