Click or drag to resize

IGH_AttributesInvalidateCanvas Method

If the mouse location should cause a canvas invalidation then return true. You only need to override this function if you draw objects that are dependant on cursor positions outside the bounds of the attributes.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
bool InvalidateCanvas(
	GH_Canvas canvas,
	GH_CanvasMouseEvent e
)

Parameters

canvas
Type: Grasshopper.GUI.CanvasGH_Canvas
Canvas to potentially invalidate.
e
Type: Grasshopper.GUIGH_CanvasMouseEvent
Event arguments for canvas mousemove.

Return Value

Type: Boolean
True if the canvas ought to be invalidated.
See Also